\extensions\toradex.torizon-1.5.1\moses-windows\moses.exe '--port', '5000'" terminated with exit code: 4294967295

I am getting an error when trying to install toradex torizon support extension on VSCode - Insiders and VScode.


The terminal process “c:\Users\user-directory.vscode-insiders\extensions\toradex.torizon-1.5.1\moses-windows\moses.exe ‘–port’, ‘5000’” terminated with exit code: 4294967295.

This does not allow me to add any devices in the Torizon extension. Please can you check this.

See attachments for further details.

It appears to be linked to the latest version of Docker desktop installed but cannot confirm this.

Docker details below.
Version

4.15.0 (93002)

Engine: 20.10.21

Compose: v2.13.0

Credential Helper: v0.7.0

Kubernetes: v1.25.2

Snyk: v1.1054.0

Greetings @SJ_BHD,

I’ve just updated my version of Docker Desktop to the same as yours. I can still install and run the VSCode extension fine it seems. What made you suspect that the issue was with the version of Docker Desktop?

See attachments for further details.

I don’t see any attachments on your post.

Best Regards,
Jeremias

By attachments I mean the screenshots above.
Suspecting it is a docker issue, because I can recently remember docker being updated. It may not be the case.

If you check the first screenshot, it tells that add device command not found. Issue likely caused by extension that contributes torizon.addDevice.

Apart from this in the output console in VScode (in Pty host), I am also getting the warning as below.
[warning] Shell integration cannot be enabled for executable “c:\Users\user-folder.vscode\extensions\toradex.torizon-early-access-1.6.5\moses-windows\moses.exe” and args [“–port”,“5000”]

In output console for Torizon, I get the following:
[00-10 11:47:14.911] Initializing Torizon Extension

[00-10 11:47:14.913] Checking system setup…

[00-10 11:47:15.479] Checking Moses …

[00-10 11:47:15.479] Starting backend local instance running on port 5000

[00-10 11:47:57.534] Cannot connect to Torizon IDE backend process.

[00-10 11:47:57.535] Torizon Extension Initialized

What is shell integration? It appears that this error is linked to shell integration for the extension. And that is stopping the Torizon IDE backend process.
How can this be resolved?

After consulting with our extensions team, they suspect possibly a corrupted file path or something similar. They recommend manually deleting the c:\Users\user-folder.vscode\extensions\toradex.torizon-early-access-1.6.5\ and c:\Users\user-folder.vscode\extensions\toradex.torizon-1.5.1 folders and reinstalling the extension may solve the problem.

What is shell integration?

Now regarding this warning message you got, this doesn’t seem to be coming from our extension, but is a more general VSCode issue. As seen in this thread: visual studio code - VSCode: "Shell Integration failed to activate" - Stack Overflow

The user here had to delete the entire VSCode folder to fix this “shell integration” message.

Try these methods and see if they help improve your situation.

Best Regards,
Jeremias

Hello @jeremias.tx ,

I have tried deleting these folders but I am still getting the same issue. I have also re-installed VSCode and tried the steps at stackoverflow, but I am still getting the same error.

Conversely however, within WSL I started VSCode and installed the Toradex support extension, it went ahead smoothly . I know it is not supported within WSL and ApolloX is but both installed perfectly in WSL.

However back in the windows environment, I have the same issue with the Toradex plugin. It appears that there is a WSL setting in the Toradex support extension that might be causing this issue?
Because if this issue were to be with vscode, then should’nt I have had the same issue within WSL?

On a seperate thread, I found the following link to WSL ports :slight_smile:

This is an issue when trying to use WSL behind a VPN and the port numbers used include port number 5000.

Is there a way moses.exe can use a different port number apart from 5000?

Is there a way moses.exe can use a different port number apart from 5000?

Yeah you can configure the extension to use a different port than the default 5000 as described here: Network Connection in the IDE Extensions | Toradex Developer Center

The setting you’re looking for is “Torizon: Backendport”. Then once you set an alternate port you can restart and it should be using this port now.

Just to make sure I understand, are you saying that the reason the extension wasn’t working in Windows was because port 5000 was already in use by something else on your system? Or is this related to WSL?

Best Regards,
Jeremias

Hello @jeremias.tx ,

It was a port number used by WSL as per the official github link from microsoft above.
Hence wanted to have a different port number for Torizon so that they dont clash.

So just to clarify is your issue resolved now? Or do you have further issues/questions here?

Clarified. Thanks.