I’m trying to add ExFat support to my image within yocto, however when I add fuse-exfat to the image_installs it says

ERROR: Nothing RPROVIDES ‘fuse-exfat’ (but /oe-core/meta-avilution-imx6/recipes-packages/packagegroups/packagegroup-xfs.bb RDEPENDS on or otherwise requires it)

I’m not sure what I’m missing.

Hi @matthewh628 , welcome to our Community.
Which BSP are you using now on Apalis iMX8? fuse-exfat is provided by layers/meta-openembedded/meta-filesystems/recipes-filesystems/fuse-exfat in Linux BSP v5.x which is based on the Yocto Project dunfell branch.

Hi @benjamin.tx,
I am using BSP v5.x, I see fuse-exfat being in the layers specified and I have the layer in my build environment, however, it still states that nothing provides it. Is it a compatible module issue? I build with MACHINE=apalis-imx8

Hi @matthewh628 , I can successfully build fuse-exfat by MACHINE=apalis-imx8 bitbake fuse-exfat . I find meta-avilution-imx6 in your log but our Yocto reference image never uses this layer. It is for iMX6, However, you are using Apalis iMX8 v1.1b. I don’t know where meta-avilution-imx6 comes from. Do you follow this page to set up Yocto Project environment?

That layer is the layer is our own. We build both imx6 and imx8 from this environment and at one point we had separate layers for both. When we went to one layer for both we just never renamed it.

do you still use MACHIE=apalis-imx8 ? or does the meta-avilution-imx6 layer also provide your own machine configuration?

@benjamin.tx I do still use MACHINE=apalis-imx8. The only machine configuration meta-avilution-imx6 provides is to append to TEZI_EXTERNAL_KERNEL_DEVICETREE_BOOT

Hi @matthewh628 , could you try MACHINE=apalis-imx8 bitbake fuse-exfat when your own layer meta-avilution-imx6 is removed? I would like to be sure this issue only affects meta-avilution-imx6. Thank

Hi @benjamin.tx, sorry for delayed response. I ran MACHINE=apalis-imx8 bitbake fuse-exfat with meta-avilution-imx6 removed and I still get Nothing PROVIDES 'fuse-exfat'

Hi @matthewh628 !

I just executed MACHINE=apalis-imx8 bitbake fuse-exfat and I had no problem with this recipe (I’m on refs/tags/5.3.0-devel-202106).

Could you double-check that you properly did the setup according to the article Build a Reference Image with Yocto Project/OpenEmbedded?

Also, check if you really have the meta-filesystems layer (and that the fuse-exfat recipe is inside the recipes-filesystem folder).

You should also have the meta-filesystems layer listed on your bblayers.conf.