Exception in TdxAllLibrariesDll.dll

I tried to update the Toradex packages to the newest version (v.2.1). After compilation I had the following exception:

Unhandled exception at 0x425F6D35 (TdxAllLibrariesDll.dll) in xxxxxxxxxx.exe: 0xC0000005: Access violation reading location 0x0000000.

According the debugger it happend while executing

adc = Adc_Init(L"ADC2");

Am I maybe missing another runtime library update? I have installed the latest sdk I could find (toradex_ce8_sdk_2.2).

Dear @andrischewo

If I read your tags correctly, you try to use our library on ‘no product’. That explains, why it fails :wink:

Sorry, I’m just joking. Please update the tags and Environment section to let us know on which hardware you try to use the libraries.

Regards, Andy

Sorry that I didn’t add the information first hand. Issue is the board is inside our prototype and hardly accessible, but I reproduced the error with another board we have laying around. I added the exact details of that board.


We have solved similar issue recently. Could you please download and test with our latest preliminary version library release from here and let us know if it doesn’t solve the issue.

That library resolved our first issue. The second issue we had was the CAN issue. The following library did the work for that ToradexCeLibraries_2.1b4323-20180222.

Additionally I had to make some adaptions in our CAN calls. Some configuration parameters weren’t supported anymore. The other thing was the changes in the tCanMsg struct. The structs in our code weren’t initialized to 0 so the additional field had invalid values it seems. It would be nice if there would be a bit more descriptive errors.

Short question regarding the interface. Is there any good reason not to switch to the “can.h” interface from the “can_imx6.h”? It’s just that it looks like the “can_imx6.h” header is a legacy artifact