Ethernet will not connect to PC and lights won't turn on

I’ve used both a crossover and gigabit ethernet cable to connect between the Colibri (on the Iris carrier) to my PC. Neither of them wanted to connect nor did the ethernet lights turned on. I connected it into a router, and the ethernet lights turned on immediately. I have tried setting various setups under /etc/network/interfaces and setting static ip’s on both ends. I am using my own custom Yocto image that is based on Colibri-iMX6_LXDE-Image_2.8b4.129-20181005.

I’m unsure if this is intentional, as I have been able to do this before with an Apalis iMX6 (but I know that has Gigabit). With the Colibri, I know it is 10/100 only.

Maybe a duplex mismatch? What does ethtool report?

Settings for eth0:
        Supported ports: [ TP MII ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
        Supported pause frame use: Symmetric
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
        Advertised pause frame use: Symmetric
        Advertised auto-negotiation: Yes
        Speed: 10Mb/s
        Duplex: Half
        Port: MII
        PHYAD: 0
        Transceiver: internal
        Auto-negotiation: on
        Supports Wake-on: d
        Wake-on: d
        Link detected: no

Hm, why 10 half? For auto negotiation that sounds rather problematic. And what exactly does the peer do?

I’m not sure why it’s at 10 half. Currently, it’s plugged into a crossover cable. My intention for the peer (my PC) is to pass in internet connection from my PC’s WiFi.

I decided to use the vanilla image colibri-imx6_lxde-image-tezi_2.8b5.156-20181228 and I’m still seeing the same results. I hope this adds some more information to what’s going on.

I believe that 10-half is the protocol at which transceivers start auto-negotiation. Since no link has been detected, auto-negotiation has not succeeded. Thus the transceiver remains at the base 10-half rate.

I connected Central Tab Jumper (JP2) and it now works. I’m unsure why it wasn’t connected in the first place, but now it works correctly.

Good catch. I completely forgot about that one.