Ethernet adapter icon missing

We’ve got a PXA270 which cannot be connected to via Ethernet. Inside the Network connections window there is “Add a new connection” but the DM90001 icon is missing.

Could there be a corrupt registry setting or is it something else?

Dear @steve274

The icon should be there, even if no cable is connected. Beside the icon in the Network Connections, there is also an icon in the system tray.

For some reason the DM9000 driver does not get loaded. A corrupt registry, or intentional disabling the driver in the registry, is one explanation. You can try the following:

  1. Clear the registry and reboot.
    If it was only the registry, the driver should get loaded again.
  2. Enable the debug messages and monitor the messages on a terminal program (9600baud, 8,N,1). If the driver gets loaded properly, you should see a message
    Loading DavicomEthernetDriver...Done.
    I assume this will not be the case. Maybe the debug messages can give a hint about the problem.

Regards, Andy

So @steve274, I’m curious if this solved your problem?

The reason I’m asking is that I am having network issues with the PXA270 as well.


I’m sorry @tbowley, I don’t now remember how or if I solved it.

And sorry @andy.tx for not responding at the time - thanks for your suggestions.