Error while adding a layer in linux using yocto project

I am using Colibri iMX6 512MBDL V1.1A with Colibri evaluation board V3.2.
I have tried to build a custom linux image using yocto project following the toradex webinars and i succeded in building the same image provided by toradex without getting any errors.
And then i tried to make modifications in the os by removing the browser and i followed the same webinar i created a new layer named “meta-procyon” and i have linked the files from meta-toradex and made the changes in the conf files as per the webinar. So while executing the command “bitbake-layers show-layers”, i am able to find the meta-procyon layer and i cant find the recipe for meta-procyon while executing the command

"bitbake-layers show-recipes" and i am not getting any errors but this layer is not added in the image. I have attached a screenshot with this where you can find meta-procyon with unknown parameters. Can i know why it shows unknown for my layer procyon?
Thanks and regards,

Hi Nishanth

bitbake prints add the beginning a list of all layers together with some git version information. If a layer is not version controlled with git it prints the unknown:unknown string instead.

Why it does not see your recipes I do not know from what you revealed.

Check the conf/layer.conf file of your layer. It should extend the BBFILES variable with the paths to the recipe files.

e.g. meta-toradex-lxde adds the following paths:
BBFILES += “${LAYERDIR}/recipes-//.bb ${LAYERDIR}/recipes-//.bbappend”