Error when trying to compile qtwebengine

Hello,

I am trying to add a web browser into my image but without success.

I tried to follow this link :Adding yocto packages | Variscite Wiki

  • meta-browser from OSsystems ( for chromium ) → failed ( no dunfell branch, I tried master branch but don’t work)
  • tried to add IMAGE_INSTALL_append = " qtwebengine-examples" in conf/local.conf

but it didn’t work.

I have the following error message :

ERROR: Task (/home/pga/yocto/kts5/build/…/layers/meta-qt5/recipes-qt/qt5/qtwebengine_git.bb:do_compile) failed with exit code ‘1’

Some errors like this :

…/…/…/…/git/src/3rdparty/chromium/v8/src/codegen/arm64/macro-assembler-arm64.h:162:29: error: no matching function for call to ‘v8::internal::CPURegList::CPURegList()’
In file included from …/…/…/…/git/src/3rdparty/chromium/v8/src/codegen/register-arch.h:16:0,
from …/…/…/…/git/src/3rdparty/chromium/v8/src/deoptimizer/deoptimizer.h:13,
from ./…/…/…/…/git/src/3rdparty/chromium/v8/src/deoptimizer/deoptimizer.cc:5,
from v8_snapshot/gen/v8/v8_base_without_compiler_jumbo_12.cc:7:
…/…/…/…/git/src/3rdparty/chromium/v8/src/codegen/arm64/register-arm64.h:576:3: note: candidate: v8::internal::CPURegList::CPURegList(v8::internal::CPURegister::RegisterType, int, int, int)
CPURegList(CPURegister::RegisterType type, int size, int first_reg,

Maybe I forgot something ?

Hi @f.mazur

What host system are you building on? Unfortunately chromium is a beast… It might be that a switch to another distribution version solves the problem. Also see this thread:

Regards,
Stefan

Hello @stefan_e.tx ,

I am currently building on a debian 9.11 64 bits, and another build ( meta-browser chromium ) fails too with this host : I have explained what happened on another topic, clang++ compiler used to build gn-native uses for unknown reason host-includes , and the compilation fails. I have launched the build on a debian 10 64 bits, it is currently running at this time , I have not yet the result of the build but it seems better.

When the build of chromium will finish, I’ll try after the build of qtwebengine ( which is also based on a specific chromium version ) on debian 10 instead of debian 9 and I will see if it solve the issue.

I don’t know why the compilation use host-includes without error from yocto “host contamination”.

Hello,

After reinstalling a fresh debian 10 install as host build chain, the yocto build works better
ok for meta-browser ( chromium ) , qtwebengine ( qt-kiosk-browser ) , meta-webkit
I am currently testing the firefox build ( it fails on other host ).

Perfect, thanks for the feedback!