Error "Unidentified USB Device"

Hi,

I’m working with a Colibri iMX6DL with WEC7 mounted on a Carrier board designed by us.
We have mounted a wifi module that connects via USB, sometimes when I start the Colibri I get the error “Unidentified USB Device: Exceed power limitation, USB device can´t be enumerated” and the wifi module does not work. What is the reason for this error? And how could I correct it?

On the carrier board we have a HUB, which connects via USB to the Colibri. From the HUB we use three outputs, one for a USB port, another for the wifi and one more for an FTDI.

Best regards

It seems that an over-current situation is reported, this may mean that the wi-fi adapter (or another of the devices connected to the hub) is requiring more power that what can be provided by the USB port.
You mentioned a hub in between, is that self-powered?
Can you also try with image 1.2, we made some changes to USB reset and power-enabling, and those may impact your issue.

We are working with the image 1.2 b3, sorry I was wrong to put 1.1.
The HUB is self-powered, takes power from an external source of 3.3v, has four channels and now we only use three, one for the wifi, another for a USB port and one for the FTDI. These three devices also have their own source.
I attach an image with the configuration that we have.

Is it possible to disable this overcurrent protection by windows registryalt text?

Yes, we have a parameter named “enableOC” that can be used to enable/disable overcurrent detection.
http://developer.toradex.com/knowledge-base/i-mx6-usb-host-and-usb-on-the-go-driver-registry-settings

Hi Valter

I created the registry as the link indicates, attached an image where you can see, but I still get the same error. As I mentioned there are times when the message does not come out and can work well with the USB port, Wi-Fi and COM ports.
Do I need another registry? or what do you think may be happening?

Best regards

alt text

In this case, it seems that the over-current condition is reported by the hub, not by the OC pin on the SOM.
All the external devices are self powered? Is power already applied on them when the hub leaves the reset state?

Hi Valter,

Yes, all devices are self powered, let me check this part of our device, it is probably a hardware error.

Thanks