Error setting U-Boot Environment


I have followed this tutorial for V2.8. The steps were very clear and laid out. In local.conf, I uncomment the correct machine and added the following two lines:

IMAGE_INSTALL_append = " mysql5"


After bitbaking, I moved the files to a flashdrive. The Toradex Easy Installer was able to identify this image, but errored out when I tried flashing it. Here is the error:

Error setting U-Boot environment
Line 1 not corrected terminated or too long
The image has not been written completely. Please restart the process, otherwise you might end up in a non-bootable system.

I am trying to get a MySQL database up and running on the Apalis iMX6. Is there a better way to go about doing this? Or, is there a way to correct this error message?

Thank you for taking the time to answer my question!

Looks like your uEnv.txt is empty. How exactly did you “moved the files to a flashdrive”?

Hello @alex.tx,

Thank you for responding to my original post! I used sudo cp -a apalis-imx6/. /media/admin1/usb-drive to copy the files over.

It looks like my uEnv.txt file is not empty, I attached it to this post. Could there possibly be something wrong with this file? If so, could you help me to fix it?

Thank you!

Hi @samantha

Usually after a successful build, there should be a Toradex Easy Installer Image (.tar) which you need to extract to the flashdrive. Did you get this .tar file?

Best regards,

Hello @jaski.tx!

Here are the contents of my folder, which include a .tar file.

Do any of these seem incorrect? Am I missing anything?

The image you posted is not shown.
Could you share the output of ls *.tar in text format? Thanks.

Yep @jaski.tx! Sorry for any confusion

Here is the output of ls *.tar:


Hi Samantha
There is no issue.

You should extract this file to the flashdrive:

same issue solved.
big thanks

Perfect. Thanks for the feedback.