Error message related to when debugging application

While working with .NET Avalonia (XAML-based application) on Vscode in an OS (Ubuntu) environment and running it in debug. I get the below error message and the code exits and debug doesn’t work. I have tried to reinstall my troadex extension, docker prune all the unused images/containers, and reinstalled Vscode as well. I was able to debug and run the application in the past, but now this error below appears any time I’m trying to run debug or run the application.

Thank you.

System.DllNotFoundException: Unable to load shared library '' or one of its dependencies. In order to help diagnose loading problems, consider setting the LD_DEBUG environment variable: cannot open shared object file: No such file or directory at Avalonia.X11.ICELib.IceAddConnectionWatch(IntPtr watchProc, IntPtr clientData) at Avalonia.X11.X11PlatformLifetimeEvents..ctor(AvaloniaX11Platform platform) in //src/Avalonia.X11/X11PlatformLifetimeEvents.cs:line 56 at Avalonia.X11.AvaloniaX11Platform.Initialize(X11PlatformOptions options) in //src/Avalonia.X11/X11Platform.cs:line 71 at Avalonia.AvaloniaX11PlatformExtensions.<>c__01.<UseX11>b__0_0() in /_/src/Avalonia.X11/X11Platform.cs:line 279 at Avalonia.Controls.AppBuilderBase1.Setup() in /_/src/Avalonia.Controls/AppBuilderBase.cs:line 303 at Avalonia.Controls.AppBuilderBase1.SetupWithLifetime(IApplicationLifetime lifetime)`

Hi @A_M,

Can you please share with us the version of your hardware board and also which version of the extension you are using?

Best Regards,

Hi Hiago,

Thank you for the support, here’s the requested information.
Hardware Version: Colibri iMX8QXP V1.0D
Troadex Extension: Troadex Torizon Support v1.5.1

Hi @A_M ,

So you’re using V1 of the extension. Looks like your project needs a library that is not being found. Try adding the corresponding Debian package by going to the Torizon extension configurations menu, and add libice6 to extrapackages, similar to the screenshot below:


After that, try debugging your project and see if your issue is solved.

Best regards,
Lucas Akira

Thank you, Lucas.