Error initializing SDHC1

Hello. I have problem flashing u-boot on fresh toradex vf61 V1.2B. When I get to command line hitting X and run:

flashloader u-boot-nand.imx

I get:

Error initializing SDHC1.

It worked when previously on 1.2A, but I’m not sure it’s related to revision. I tried to create sd card several times, use different sd cards, use diferent toradex modules (all of them 1.2B since I don’t have 1.2A anymore), but with the same error. The module is on our custom board, but it worked before and it’s the (exact) same custom board, so it’s probably issue with eboot I gues.

Thank you.

Could you try to use different carrier board? Symptoms look like broken SD card holder.

Thanks for reply, I forgot to mention that I already tested it on two devices (same type) with same result. Was there some hardware or firmware change between 1.2A and 1.2B that could cause this? Or is there some way to get back to eboot so I can try if it still works on 1.2A? Thanks again.

hi @radoslavp

There was no hardware changes regarding MMC interface as described here.

Which version of U-Boot are you using?

Best regards,

Thank you for reply. Didn’t you mean eboot version (I have problems to flash u-boot from eboot environment)? If yes, it’s:
Toradex Bootloader 1.5 for Vybrid Built Dec 18 2017.

U-boot version is: U-Boot 2015.04+fslc+g10bc451 (Jun 26 2017 - 14:30:20).

Today I actually tested it on your evaluation board and it works (except I had to add colibri_vf to the path, but I saw that mentioned somewhere in your wiki). I don’t know if there is any difference, regarding mmc, between your eval board and our custom board (I don’t understand it that well), but could it be that there was a change in eboot that causes this? Because I used our custom board for u-boot flashing previously and it worked and have never used eval board before.

Dear @radoslavp,

Do you mean to say following this step : solving the issue?

The colibri_vf not related to the carrier board, it is directory path. Getting u-boot from subfolders implemented from V1.3 release onwards,

Hi, @raja.tx. No, I just wanted to say that using different carrier board did solve the problem - or was a workaround - it still doesn’t work with our custom carrier board. So I’m curious if there is any chage in eboot regarding mmc? Nevermind the note about colibri_vf.

Dear @radoslavp,

Thank you for the replay and patience.

We didn’t change anything related SD card specific to carrier or eval board that you can confirm here. If it is working on the eval board then it should work on the carrier board.

Only Flash part is changed in HW V1.2B that require WinCE SW v1.5 should be used on the module.

Hence it would like to suggest you below testing and let us know result.

Could you program the latest WinCE Image on Vybrid somehow. Make FAT formatted SD card.

  1. Boot the module with Colibri Evaluation board and wait for WinCE complete booting and verify the inserted is mounting on the WinCE device by looking into My device directory.
  2. Follow procedure 1 with carrier board.
  3. Follow procedure 1 with your custom board.

If your different SD card detect pin and polarity then please configure through the registry :

If the above test results pass then we can confirm that SD card interface is working in all the carrier/eval board then we should similar testing in e-boot level to verify which carrier and eval board is working?

Please confirm/share below HW and SW details, it will help us to make similar setup and look the issue.

  • SOM : Colibri VF61 256MB IT V1.2B
  • Carrier and Eval board details?
  • WinCE Software version? As per your details, you are using v1.5 WinCE software.
  • Do you want to program WinCE or Linux on your vybrid module finally?
  • I guess, are you trying to program Linux on the shipping vybrid module? (default WinCE is programmed and shipped from our side).