Error Flashing u-boot

Hello, I am trying to flash a linux image from E-boot as per instructions: “Flashing Embedded Linux to Vybrid Modules

However I get the following error when trying to flashload u-boot:

Error opening image file. The file must be in the root folder of the first part.

I am using a Colibri VF61 V1.2A and iris V1.1A. And the E-boot version that came with the Colibri was “Toradex Bootloader 1.2 for Colibri Built Sep 4 2015”

Up to this point everything was running smoothly. I am using a sd card with a FAT32 partition. I have tried copying the u-boot-nand.imx outside of the “colibri-vf/” folder and execute both of these commands with the same error.

flashloader colibri_vf/u-boot-nand.imx
flashloader u-boot-nand.imx

I have tried using multiple sd-cards with no success and even different host machines to flash the image.

What am I doing wrong?

Also note that this isn’t the first time I am encountering a problem flashing a Linux image into Colibri. Every single time I bypassed this by flashing from scratch using the recovery mode. But It doesn’t seem right to me that I would have to do that every time I wanted to install Linux.

Thank you in advance.

I think some versions of Eboot had troubles with certain partition tables. Can you make sure to re-partition the SD card and recreate a FAT file system?

I have just tried formatting the micro sd card using only one partition using a FAT file system. I have tried with FAT32 and FAT16. No luck, same errors.

And partition table msdos. It seems to be correct to me, unless I am missing something.

Can you please download this → and use Win32DiskImager to burn it to SD card and try to flash u-boot then.

just type flashloader u-boot.imx

This worked and installed u-boot without needing to go through the recovery mode.
But is this a problem for recent versions of e-boot? Because it happened with all of my Colibri VF61?

so far I figured out that some SD cards have issues. I have some that work and some that don’t so I created you the image of one that works. I think you could also use update tool to flash u-boot. Just download latest image from web and copy Update Tool to SD Card/USB drive. Boot Windows and run Update tool selecting u boot file

I understand, thank you for the answers and all the help. I will try using the update tool next time.

I am trying to update uboot from eboot.I am using iris carrier board with vf50 module.So i’m getting below error,
Error initializing FAT on SDHC1.Please help to resolve.

Thanks in advance.

Did you try the solution I provided to the question above?