Error during building v4l-utils with Apalis-iMX6_LXDE-Image_2.8b3.111-20180626

Dear all,
I`m building linux image from repo

repo init -u -b refs/tags/Apalis-iMX6_LXDE-Image_2.8b3.111-20180626
 repo sync

but during build I’m facing an error:

| Making all in cec-ctl
| make[3]: Entering directory '/home/kamil/apalis/imx6/oe-core/build/tmp-glibc/work/armv7at2hf-neon-angstrom-linux-gnueabi/v4l-utils/1.12.3-r0/build/utils/cec-ctl'
| ../../../v4l-utils-1.12.3/utils/cec-ctl/ 0 ../../../v4l-utils-1.12.3/include/linux/cec.h ../../../v4l-utils-1.12.3/include/linux/cec-funcs.h >cec-ctl-gen.h
| arm-angstrom-linux-gnueabi-g++  -march=armv7-a -mthumb -mfpu=neon -mfloat-abi=hard --sysroot=/home/kamil/apalis/imx6/oe-core/build/tmp-glibc/work/armv7at2hf-neon-angstrom-linux-gnueabi/v4l-utils/1.12.3-r0/recipe-sysroot -DHAVE_CONFIG_H -I. -I../../../v4l-utils-1.12.3/utils/cec-ctl -I../..   -I../../../v4l-utils-1.12.3/lib/include -Wall -Wpointer-arith -D_GNU_SOURCE -I../../../v4l-utils-1.12.3/include   -O2 -pipe -g -feliminate-unused-debug-types -fdebug-prefix-map=/home/kamil/apalis/imx6/oe-core/build/tmp-glibc/work/armv7at2hf-neon-angstrom-linux-gnueabi/v4l-utils/1.12.3-r0=/usr/src/debug/v4l-utils/1.12.3-r0 -fdebug-prefix-map=/home/kamil/apalis/imx6/oe-core/build/tmp-glibc/work/armv7at2hf-neon-angstrom-linux-gnueabi/v4l-utils/1.12.3-r0/recipe-sysroot-native= -fdebug-prefix-map=/home/kamil/apalis/imx6/oe-core/build/tmp-glibc/work/armv7at2hf-neon-angstrom-linux-gnueabi/v4l-utils/1.12.3-r0/recipe-sysroot=  -fvisibility-inlines-hidden -c -o cec-ctl.o cec-ctl.cpp
| arm-angstrom-linux-gnueabi-g++: error: cec-ctl.cpp: No such file or directory
| arm-angstrom-linux-gnueabi-g++: fatal error: no input files
| compilation terminated.
| Makefile:531: recipe for target 'cec-ctl.o' failed
| make[3]: *** [cec-ctl.o] Error 1
| make[3]: Leaving directory '/home/kamil/apalis/imx6/oe-core/build/tmp-glibc/work/armv7at2hf-neon-angstrom-linux-gnueabi/v4l-utils/1.12.3-r0/build/utils/cec-ctl'
| ERROR: oe_runmake failed
| Makefile:468: recipe for target 'all-recursive' failed
| make[2]: *** [all-recursive] Error 1
| make[2]: Leaving directory '/home/kamil/apalis/imx6/oe-core/build/tmp-glibc/work/armv7at2hf-neon-angstrom-linux-gnueabi/v4l-utils/1.12.3-r0/build/utils'
| Makefile:574: recipe for target 'all-recursive' failed
| make[1]: *** [all-recursive] Error 1
| make[1]: Leaving directory '/home/kamil/apalis/imx6/oe-core/build/tmp-glibc/work/armv7at2hf-neon-angstrom-linux-gnueabi/v4l-utils/1.12.3-r0/build'
| Makefile:501: recipe for target 'all' failed
| make: *** [all] Error 2
| WARNING: exit code 1 from a shell command.

I have found how to resolve similar problem which is available on the web link text, but didn’t try yet because I’m still during first compilation. Please check if you encounter the same error and Can I use fix from this web page?

We have not seen this issue during our builds.

Do you use additional layers/custom local.conf or did you some changes to layers otherwise?

What build host distribution are you using?

Yes, the last suggestion (using autotools-brokensep) in the v4l-utils recipe might help. Please let us know if it fixes the issue for you.

I actually also saw this problem while building for “apalis-tk1”. Using autotools-brokensep did resolve it for me.

Strangely, I don’t require this patch when building on my Ubuntu 16.04 box with an installation of Ubuntu 16.4 from a couple of years ago. Those builds still work fine for me. However, I just now encountered it when setting up a VM for a teammate using the newest Ubuntu 16.04 available. I chose not to upgrade to Ubuntu 18.04 because of unavailable package dependencies…

Thanks for this Information.
@kamil: Could you check, if this information is a help for you. What is your host distribution?

Hi @jaski.tx, My host distribution is: Ubuntu 16.04.2 LTS, and yes adding autotools-brokensep, helped to resove this issue. I have Ubuntu 16.04.2 installed as a virtual machine, and started from oracle virtual box under windows 10.

Perfect, that it works. Thanks for the feedback.