Enable DE mode in imx6 for 7" resistive touch display

I am using colibri imx6 with voila plus for 7" display. (G070VTT01-AUO) . This display support DE mode only. It not have any vsync and hsync. How and where i can make changes to enable DE mode in imx6 (means which dtsi file and what parameter). my parameters are as attached.link text

Dear @deepakrajpoot

Thank you for contacting Toradex Community!

Please kindly refer to the following artcles to enable Vsync and Hsync for the Display with iMX6:
https://developer.toradex.com/knowledge-base/display-output-resolution-and-timings-linux#iMX_6ULL_and_iMX_7_Framebuffer_Boot_Configuration

https://developer.toradex.com/knowledge-base/display-tool

Hope this answer helps!

Best Regards,
Janani

I had gone through this document. I am using linux(lxde). Where i make change to enable DE mode because support LCD with i have purchased for toradex do not have DE mode.

Dear @deepakrajpoot,

Thank you for your message. You could try the following to get your display up and running:

  1. We advise you to set-up display configuration in U-boot (https://developer.toradex.com/knowledge-base/display-output-resolution-and-timings-linux#iMX6_Multiple_Outputs) and saveenv. Please make sure to enter your display resolution and RGB (based on the bit), depending on the monitor. This shoudl solve the issue

  2. If the issue still persists, you can modify the file ( drivers/video/fbdev/mxc/mxc_lcdif.c ) with the necessary vsync and hsync settings (from the monitor’s datasheet) and re-compile the kernel.

Thank you and regards,
Janani.