Enable additional SD interfaces on Colibri iMX6

I have a Colibri iMX6 board with 2 SD card sockets connected on following pins as recommended in Colibri iMX6 Datasheet (http://docs.toradex.com/102075-colibri-imx6-datasheet.pdf):

  • SD1_CD_B: pin 43

  • SD1_CLK: pin 47

  • SD1_CMD: pin 190

  • SD1_DATA0: pin 192

  • SD1_DATA1: pin 49

  • SD1_DATA2: pin 51

  • SD1_DATA3: pin 53

  • SD1_WP: pin 28

  • SD2_CD_B: pin 174

  • SD2_CLK: pin 93

  • SD2_CMD: pin 69

  • SD2_DATA0: pin 98

  • SD2_DATA1: pin 106

  • SD2_DATA2: pin 130

  • SD2_DATA3: pin 99

  • SD2_WP: pin 180

The first SD card (SD1) works well but I don’t get the second SD card (SD2) running. I tried to add following registry keys as described in http://developer.toradex.com/knowledge-base/pin-multiplexing-for-drivers:

[HKEY_LOCAL_MACHINE\Drivers\BuiltIn\USDHC2\Pinout_Default]

  • “colibripin_99”=“altfn=0”
  • “colibripin_130”=“altfn=0”
  • “colibripin_106”=“altfn=0”
  • “colibripin_98”=“altfn=0”
  • “colibripin_69”=“altfn=0”
  • “colibripin_174”=“altfn=6 dir=in”
  • “colibripin_180”=“altfn=6 dir=in”
  • “colibripin_93”=“altfn=0 dir=out”

Still the driver is not being loaded for SD2. Are there any other registry settings needed?

@widtmann,

Which WEC7 image version you are using now? Please verify it using Updatetool ( Start → Programs → ColibriTools → UpdateTool, Version info button).
Second SD interface feature is implemented in 1.1 Beta 4 (http://developer.toradex.com/software/windows-embedded-compact/imx6-wec-software/release-details?view=all&issue=20559). Please use latest image release and let us know if you still face the problem.

I’m using Windows EC7 BSP 1.2 Beta, Build 6. I loaded it a week ago using the Toradex Easy Installer.

You may switch to release 1.2 (latest stable release and more recent than 1.2b6) or 1.3b2 (newest beta release), I would suggest 1.2 if you don’t need any of the new features of 1.3b2.
In any case, as Raja said, second SD slot is supported since 1.1b4 release.
In terms of GPIO configuration:

@widmann
Could you please download and import the registry, save registry and reboot.
Let us know if that helps for you.

Thank you for the hints! The additional registry settings solved my problem. The additional SD card works perfectly now.

Thank you.