Embedded wifi module giving continuous errors

I am using a Colibri iMX6ULL with embedded wifi/bluetooth with Console Image 2.8b3.11 Linux.

As soon as I enable the wifi using

$ connmanctl enable wifi 

I get this error continuously

ieee80211 phy0: mwifiex_cfg80211_sched_scan_start : Invalid Sched_scan parameters

Note that using # systemctl list-units indicates that wpa_supplicant is running

wpa_supplicant.service                                       loaded active running   WPA supplicant

howeever I dont have wpa_supplicant.conf file.

i just want access point uap0, not mlan0 client.

I presume the error is because i have not configured the mlan0 client to work correctly.
Is there a way to disable the client side if i only want the access point to work?
Or is this problem instrinsic to the wifi module so that the problem occurs irreslective of client or access point ?

Any help in solving the problem would be appreciated.

Hi @lachlanp

Are you able to configure the access point with the uap0? I also get this message on my iMX6ULL, independent whether I have BSP version 2.7 or version 2.8 installed. I’ll need to check that with my colleague on Monday.
If you are not able to configure and start the access point, please try the BSP version 2.7.

Thank you and best regards, Diego

The access point works and I can connected via wifi and load a web page. However, in the debug console I get the indicated message with or without the uap0 enabled and working.

Perfect that access point is working. For the messages, we will look into it and come back to you.

That’s not an error, just a verbose print. connman GUI schedules wifi scans with a parameter that’s not supported by firmware in our wifi module. If you don’t want connman to handle mlan0 interface you can try adding mlan to NetworkInterfaceBlacklist in /etc/connman/main.conf

I am using IMX6ULL Console image 3.0b3 on Colibri eval board v3.2B with Colibri IMX6ULL 512MB WB IT V1.1A, and am seeing the same issue where the debug console showing “ieee80211 phy0: mwifiex_cfg80211_sched_scan_start : Invalid Sched_scan parameters” periodically. Note that WiFi AP (interface uap0) is enabled.

I followed the previous recommendation to black-list mlan0 in connman/main.conf but that does not resolve the issue.
NetworkInterfaceBlacklist = vmnet,vboxnet,virbr,ifb,ve-,vb-,usb,rndis,mlan0

Below is the wifi interfaces:

iw dev

Interface uap0
ifindex 5
wdev 0x2
addr d0:c5:d3:9b:4a:09
ssid titanHubby001
type AP
channel 1 (2412 MHz), width: 20 MHz (no HT), center1: 2412 MHz
txpower 0.00 dBm
Interface mlan0
ifindex 4
wdev 0x1
addr d0:c5:d3:9b:4a:09
type managed
txpower 0.00 dBm

Hi @SSL, your issue will be discussed here.

Thanks and best regards,