Easy Installer with BSP image from USB drive

Hi all

I’m trying to install a BSP image on my Colibri iMX7 which is on a Colibri Evaluation Board. Due to company connectivity issues, I’m trying to go the offline route via a USB drive.
What I did:

so far it looks all good, but when trying to install an error pops up saying:

Error executing prepare script

/run/media/src/prepare.sh: line 7: :
:not found

/run/media/src/prepare.sh:
line 12:
:not found

/run/media/src/prepare.sh: line 14:
can’t create 2 : Read-only file system

/run/media/src/prepare.sh: exit: line
15: illegal number: 1

The image was not written completely.
Please restart the process, otherwise
you might end up in a non bootable
system.

Any ideas on that?

Cheers, benjamin

hi @benjo

Welcome to the Toradex Community!

Could you provide the version of the Toradex Easy Installer?

Unpacked the content of the folder “.\Colibri-iMX7-eMMC_LXDE-Image_2.7” of the *.tar archive to a FAT32 formatted USB drive

How did you unpacked the .tar archive?
Did you extract the content to the main folder of the USB drive or did you copy the whole folder?

Did you retry to install the image using USB drive? Did it work?

Best regards,
Jaski

Hi @jaski.tx

The Easy Installer is V1.8 (g9bc7d7b)

The *.tar file has a folder structure “.\Colibri-iMX7-eMMC_LXDE-Image_2.7” inside. I unpacked the content of the folder “.\Colibri-iMX7-eMMC_LXDE-Image_2.7” to the USB drive.

Cheers, benjo

Hi, Thanks for the Info.

I tested this using SD card and it works fine.
Which carrier board are you using? Did you sync before you removed the USB key from your host?

Hi @jaski.tx

the carrier board I use is the Colibri Evaluation Board V3.2B.
I prepared the USB drive on a windows machine, so instead of sync, I just used the “eject” option which should just do the same.

I’ve tried different USB drives, different images (stable and beta), plugged the USB drive into the USB host and the OTG connector. Just can’t get it to work.
I would try SD card if I had one at hand, but I don’t.

I also tried both iMX7 boards I currently have.

Hi

We never tried this using Windows, since it is a Linux Image. Could you use Linux on a VM or native Linux to extract the content.

By the way, which windows versions and which tool did you use to extract the files?

I assume that extracting from windows changed the attributes of the files and that’s why it is not working.

hi @jaski.tx

It’s a windows 7 machine. I’ve now prepared the USB drive with a raspberry pi and it worked just fine to install the image.
Still, I think the dependency on linux is a drawback.

Thanks for helping me!

cheers, benjo

Perfect that it works. Thanks for the feedback.

Still, I think the dependency on linux is a drawback.

Usually if you are using Linux on the module, you will need to have Linux on your Host for compiling the Image and Application for your module.

Best regards,
Jaski

I haven’t tried it but the only problem should be ownership/permissions… It shouldn’t be very difficult.

Still, I think the dependency on linux is a drawback.

I only have a Windows 7 machine, so I had to resort to running VirtualBox with a Ubuntu 16.04 install. Using this, I’m able to build new device trees and kernels without issue. With VirtualBox you can pass a USB device through the Windows environment and into the Linux kernel, and I’ve used this method to prepare a USB key for flashing an iMX7 device. I’ve also passed the USB OTG port on the Evaluation Board into my VirtualBox machine, and have been able to follow the Getting Started Guide and connect from Eclipse into the iMX7 over the USB network.

It isn’t ideal, but is a successful work around when I can’t install Linux on my development machine.

Thanks for your valuable Input.