Easy installer fails HID(W):LIBUSB_ERROR_IO

Using a Colibri IMX8X modules I tried to load the recovery mode but I keep getting the error:

> recovery-windows.bat
Downloading Toradex Easy Installer...
uuu (Universal Update Utility) for nxp imx chips -- libuuu_1.4.127-0-g08c58c9

Success 0    Failure 1

3:12     1/ 1 [HID(W):LIBUSB_ERROR_IO                ] SDPS: boot -f ../imx-boot

ECHO is off.
Downloading Toradex Easy Installer failed...
Press any key to continue . . .

Which in itself says little to nothing… Tried on Windows10 and on ubuntu 20.4 both give the same error. Both find the chip when using

>uuu -lsusb

Connected Known USB Devices
        Path     Chip    Pro     Vid     Pid     BcdVersion
        3:12     MX8QXP  SDPS:   0x1FC9 0x012F   0x0002

Any idea on what I’m doing wrong here? I’m using the Colibri-iMX8X_ToradexEasyInstaller_5.5.0+build.6

for the colibri with IMX8DQXPRM

Greetings @davygillebert,

What version of the Colibri i.MX8X do you have? (The version on the sticker)

In the past we’ve had 2 variants of the i.MX8X with different silicon. Which required slightly different software. This may cause the issue you are seeing. So please let me know what the exact version is on the hardware.

Best Regards,

Below is the information on the sticker. I know about 1.5years ago we managed to get them into recovery mode as that’s when we initially experimented with this board and got a custom linux build on them.


Hi @davygillebert ,

With iMX8 modules, it is important that you wait at least 8 seconds after booting before you start the recovery-script. When you launch the script before the module is fully in recovery mode this error message can appear.

Can you confirm that this is the method you used?

Best Regards

I’ve now made certain I wait well over 8 seconds and still the same issue.

Hi @davygillebert ,

Thank you for testing it.

On what carrier board are you doing these tests? Is it a custom one or are you using a carrier board from Toradex?

Furthermore, would it be possible that you attach all the errors you got on Ubuntu 20.04 ?

Best Regards

Last attempt was on windows10 its a custom board where we have the recovery pin connected to a button

Hi @davygillebert,

Could you try to reproduce it on a Toradex Carrier Board and confirm if the behaviour is the same?

Best Regards

We do not own such carrier board. About 1.5 years ago we have gotten them into the recovery mode (back then on a ubuntu pc) so I’d doubt it’s the hardware except if something (drastically) changed from the version we have to the current version which would need us to redesign our own board to get it working. (or would mean the image we try to flash is not possible on the old colibri module)

Hi @davygillebert,

Thank you for replying with the hardware version information.

Judging by the information you provided, the issue does appear to be what I initially thought. So the 1.0B version uses old silicon that actually requires different software compared to the current 1.0D versions. Furthermore since the silicon is old and this version is no longer sold by us, we stopped supporting this version in our 5.5.0 software.

With that said, the version of the hardware you have and the version of Easy Installer you are trying to use are incompatible. So you have two options now to move forward here.

The best option in the long-run would be to procure 1.0D versions of this module. This way you’ll have proper software support again going forward.

The other option would be to use old software that still supported the 1.0B. This is V5.3.0 of Easy Installer, which should still have support for 1.0B: https://artifacts.toradex.com/artifactory/tezi-oe-prod-frankfurt/dunfell-5.x.y/release/3/colibri-imx8x/tezi/tezi-run/oedeploy/Colibri-iMX8X_ToradexEasyInstaller_5.3.0+build.3.zip

However you should still try to procure up-to-date modules otherwise you’ll not be able to make use of our more recent software releases (5.5.0 and onward).

Best Regards,