Dll fails to run on toradex image

i get the following error when i run my application
ExceptionCode: 0xc0000005
ExceptionAddress: 0x42637bd8
Reading: 0x00000000
Faulting module: arcb3pinvokable.dll
Offset: 0x00017bd8

at Arcb3PInvokablePINVOKE.ReaderImpl_TagIdentify(IntPtr jarg1, UInt32& jarg2)
at ReaderImpl.TagIdentify(UInt32& pAirSpeed)
at ArcontiaReader.SelectTag()
the dll is dependent on the following: WINSCARD.DLL , COREDLL.DLL, which are all in the build.
there is nothing wrong with the dll as it is running on another ce device non-Toradex. on both wce6 and wce7. attached are 2 dlls used. compact framework 3.5 is installed
Arcb3PInvokable.dll (1.8 MB)
Arcb3DotNetLibCompact.dll (517 KB)

That exception is a very generic Access Violation. It happens if application is trying to access something in memory which does not belong to it.

In managed application it generally caused by incorrect P/Invoke or incorrect unsafe code usage.

If you using native DLL it can come from that native DLL due to incorrect parameters been passed or due to bug in it. In many cases Access Violation manifests itself in completely irrelevant part of the application because memory or stack have been corrupted at some point by other portion of the code.

You can try to enable debug messages and collect log from UART1. Please also provide a BSP version you are using.

The problem was that UART3 was not enabled was used as USB otg so the dll failed to use it

Glad your problem solved. Thanks for the update.