Display Problem with Capacitive Touch Display 7" Parallel on WEC2013, IMX6S

Hello,

I bought a Capacitive Touch Display 7" Parallel and I’m trying to make the display work (the multitouch will come after). I’m using this link : First Steps with Capacitive Touch Display 7" Parallel

I could not get the display for now, I tried different configuration in Display Tool in WEC2013 (Colibiri Imx6xxx EDT 800x480 for example) but it does not work. I am missing Something ? I connect the display to colibri evaluation board 3.2A (just the display cable for now) like the photo. I saw a little flash light (for less than a second) on the display when I power on the board, but Nothing else. can you help me please? thanks.

link text

If you look at the video, it seems that the system start correctly but I have no display. It is only when I press the reset button on the evaluation board that I saw the system on screen…

Did you try to connect a VGA monitor? Does it work?
If it works you can use a Colibri Tweak tool and select your monitor from “preset” drop list.
Otherwise you can use either remote display and do the same or use a Eboot display setting ability.

Could you please specify BSP version you are using?

I have a VGA monitor also connected which works well. Can you look at my video in the second comment ? you will understand better my problem.

Is it possible to make it work in both display (vga monitor and 7" display) at the same time ?
with or without vga monitor connected aside, the problem is the same here.

Yes it possible but LCD display has limited modes support. So you need to set video parameters according to your LCD display. VGA monitor usually supports wider sets of modes.

I’ve seen your video but it doesn’t show a VGA monitor.

Could you please install a latest WEC release (v1.6) and check a display behavior?

The VGA monitor is in the back, because I’m only interested to make the display work. with release 1.6, it is the same problem. I Don’t think it is coming from video parameters because I have the same behaviour with correct or “incorrect but working” parameters for the display.

After some research, I found on the datasheet of the LCD display that the PWM value have to be set to 0 to have 100% brightness, maybe the problem is coming from here.

When I check voltage value at sodimm 59 (PWM_A), the voltage is to 3.3V so maybe that is the problem, but when I try to set the PWM to 0 (via a PWM_Demo), there is no change. It said on display datasheet that typical frequency is 150Hz, so I tried to set 0 at 150Hz on Sodimm 59, but no change…

after another check, when I press the reset button, the voltage value at sodimm 59 is 0V, that’s why we have this behaviour on the video. The problem now is why I can’t set the pwm value to 0… I use basically this code below

pin_backlight1 = new gpio.uIo();
pin_backlight1.number = 59; //Pin number
pin_backlight1.type = (ushort)gpio.tIoType.ioColibriPin;

pwmHandle_C = pwm.Pwm_Init(“PWM3”); ///< Init PWM3 handle
pwm.Pwm_SetConfigInt(pwmHandle_C, “io”, pin_backlight1.GenericDefinition, TdxCommon.ParamStorageType.StoreVolatile);
pwm.Pwm_SetConfigInt(pwmHandle_C, “BaseFreq”, pwmBaseFreqDemo, TdxCommon.ParamStorageType.StoreVolatile);
pwm.Pwm_Open(pwmHandle_C); ///< Open PWM library
pwm.Pwm_SetPwm(pwmHandle_C, 150/Hz/, 0/of 65536/);

It’s nothing to discuss if BSP version is unknown. I also take a note that you video shows sows some custom application is running. It can alter display settings as well.

Please install a latest WEC release (v1.6) and check a display behavior.

I already said that I have the same problem with release 1.6. I tried with last bootloader and last release. the problem is the same.
In updatetool, it does not give me the bsp version.

Could you please do a fresh and clean install of 1.6 BSP with no any additional application installed and make a video of screen behavior?

can i know how to make a fresh and clean install ? thanks

By using Toradex Easy Installer

I had a last empty colibri card so I make an new setup on this card, and Indeed, it works, and the voltage at sodimm 59 is 0V.

I still did not get why I have 3.3V on the other card, but I will try a fresh and clean install on this one like you said.

At least I understood how the display works :slight_smile:

have a nice day.

Thanks for update.