Disabling clock out on the Microchip MCP2517/18 CAN controller

Hi @jaski.tx, @matthias.tx, @Edward, @harricane, @gauravks
I thought you might be interested in the response I got from Microchip when following up with them on some noise sources on my board. That is described here

Their recommendation is to switch the CLKO pin from clock mode to start of frame mode using bit 29 (SOF) in the IOCON register.alt text

This leads me to the questions:

  • What mode is currently set in the driver in Torizon?
  • How can we change that setting?

Thanks very much


Hi @edwaugh ,

Assuming you are using mcp25xxfd driver, when driver has priv->config.clock_odiv==0 CLKO should switch to SOF. Default clock_odiv setting is 10, which is divide by 10. According to mcp25xxfd_clock.c

	priv->config.clock_odiv = 10;
	ret = of_property_read_u32_index(np, "microchip,clock-out-div",
					 0, &val);

You should add in DT for your MCP2517/18 instance microchip,clock-out-div = 0


Hello I am Adding @jaski.tx here.

Best Regards,