Disable SSH access of toradex reference image

Hello All,

We are using Apalis i.MX8 and toradex reference multimedia image for development.
I am trying to find way to disable and enable ssh access of the board as and when required.
I tried to find any documentation for it but I could not find it this image.
I tried to check for ssh configuration files in /etc/ but could not find any config file.

Please share if there is any reference how can I disable/enable ssh access of the board.

Prathamesh Kulkarni

To disable SSH access, you would stop the SSH service. This can usually be done with the following command:

sudo systemctl stop sshd.socket

To re-enable SSH access, you would start the service again using:

sudo systemctl start sshd.socket

You can check the status of the SSH service to see whether it’s active (running) or inactive (stopped) with:

systemctl status sshd.socket

If you want to disable SSH from automatically starting at boot:

sudo systemctl disable sshd.socket

SSHD configurtaion file location is


Hi @alex.tx ,

Thanks for sharing your input. I tried this way on the device. But unforfunately there is no sshd.socket systemd unit available.

root@apalis-imx8-07106406:~# systemctl status sshd.socket
Unit sshd.socket could not be found.

The file ssh_config is also not present.

root@apalis-imx8-07106406:~# ls /etc/ssh/sshd_config
ls: cannot access ‘/etc/ssh/sshd_config’: No such file or directory

We are using toradex reference multimedi image. Could you please share any other way to disable/enable ssh?

Prathamesh Kulkarni

Hi @alex.tx ,

I found that dropbear is used in this image.

root@apalis-imx8-07106406:~# ps -el | grep -i dropbear
4 S 0 966 1 0 80 0 - 717 do_sel ? 00:00:00 dropbear
4 S 0 1676 1 0 80 0 - 717 do_sel ? 00:00:00 dropbear
4 S 0 1773 1 0 80 0 - 717 do_sel ? 00:00:08 dropbear
4 S 0 2081 1 0 80 0 - 717 do_sel ? 00:00:00 dropbear

I tried to disable dropbear using systemctl,
but I am not able to disable dropbear.

root@apalis-imx8-07106406:~# systemctl status dropbear@
Failed to get properties: Unit name dropbear@.service is neither a valid invocation ID nor unit name.
root@apalis-imx8-07106406:~# systemctl status dropbear
Unit dropbear.service could not be found.

Please share your input on this.

Prathamesh Kulkarni

Hi @prathamesh.kulkarni,

If you are not sure about exact service name, you can check for service using below command and once you get correct service name disable using systemctl.

systemctl | grep -i dropbear
systemctl list-unit-files --state=enabled

Best Regards
Ritesh Kumar