Disable serial console for Apalis i.MX8

Hello All,

We are using Apalis i.MX8 SOM along with Yocto Project Toradex Reference Multimedia Image for development.
We need to disable login prompt and serial console messages for U-boot as well as Kernel. I am following below article for disabling the serial console.

I have not tried to disable U-boot messages yet.
I tried to disable kernel logs using steps given in the article.
I set tdxargs u-boot environment variable using below commands given in the article.

setenv tdxargs ‘console=null’

I also tried to set it from user space.

fw_setenv tdxargs 'console=null

I could see that the tdxargs variable value is set properly. But the serial console and log messages were still active.

Please share your input on this.

Prathamesh Kulkarni

Hi @prathamesh.kulkarni ,
What is the image version you are using ?
Also share the logs that you are getting after disabling the kernel logs

Hi @sahil.tx ,

Sorry for the delay in response.
I have attached log file here.
disable_serial_console_logs.txt (47.0 KB)
I am not sure about where I can find image version.
I found below details about the image.

root@apalis-imx8-06980499:~# cat /etc/os-release
NAME=“TDX Wayland with XWayland”
VERSION=“5.7.1-devel-20231129150039+build.0 (dunfell)”
PRETTY_NAME=“TDX Wayland with XWayland 5.7.1-devel-20231129150039+build.0 (dunfell)”

root@apalis-imx8-06980499:~# cat /etc/version

Prathamesh Kulkarni

Hi @sahil.tx ,

Please share your input.

Prathamesh Kulkarni

Hi @prathamesh.kulkarni ,
Can you check if this works for you

setenv tdxargs ‘${tdxargs} quiet’

Hi @sahil.tx ,

I checked above command. It does not work for me.


Hello @sahil.tx ,

I checked the command again, this time it worked for me. But some how few log lines still appear.
Also, I want to disable login prompt, I am able to disable it by masking getty.target using systemctl.
How can we disable getty.target from Yocto build?

Prathamesh Kulkarni

Hi @prathamesh.kulkarni ,

This is expected as it gives you very few debug messages but does not disable all.

For disabling serial getty using yocto, can you check this similar post