Disable serial boot loader in L4T

Hi
I wanna disable serial console(ttyS0 on X22) boot loader on ready to use L4T to use ttyS0 in my application as ordinary serial port. i read this article

https://developer.toradex.com/knowledge-base/how-to-disable-enable-debug-messages-in-linux

but it seems this article describe it during linux built process
and not applicable for downloadable ready to use L4T(UBUNTU 14.04)
what should i do in this case ?

Best Regards

HI @toradexvision

How many UART Ports do you need for your application?
Why cannot you use the other UART Ports?
What about a USB to UART Converter?

but it seems this article describe it during linux built process and not applicable for downloadable ready to use L4T(UBUNTU 14.04) what should i do in this case ?

In the default Bsp, this port is used for the console output. If you want to change this, then need to follow this.

Addtionally, if you also want to disable the console also in U-Boot, then you will need to build a custom U-Boot.

Best regards,
Jaski

Hi Jaski

i need 4 serial port in my application
i wanna use /dev/ttyS0 , /dev/ttyTHS1 , /dev/ttyTHS2, /dev/ttyTHS3

and on /dev/ttyTHS3 i use UART to RS232 converter

is there any other options exist on ixora for use as RS232 or UART?

and perhaps you know i try to install mpci card (EMP2 X403) for add 4 more port .
but unfortunately I still couldn’t do it .

Best Regards

HI

is there any other options exist on ixora for use as RS232 or UART?

Yes, use an USB to UART Converter.

and perhaps you know i try to install mpci card (EMP2 X403) for add 4 more port . but unfortunately I still couldn’t do it .

Yeah, I will look into this.

Best regards,
Jaski

Hi Jaski

according to your above link to disable serial boot loader on ttyS0 in Ubuntu 14.04
i have problem:

root@tegra-ubuntu:/home/ubuntu/#apt-get install u-boot-tools
 root@tegra-ubuntu:/home/ubuntu/#fw_setenv console null
cannot parse config file:no such file or directory
Error: environment not initialized

it seems not work for ready to use L4T in your site.

Best Regards

Hi

The Problem is on JetPack/Ubuntu side. You can stop in U-Boot and disable the console.

Best regards,
Jaski