Disable network time synchronization


I’d like to disable time synchronization with NTP server one time that won’t be enabled after turn a power or rebooting. But the ways that I found disabled synchronization only for current session:

> busctl --system call net.connman / net.connman.Clock SetProperty sv "TimeUpdates" s "manual"
> systemctl disable systemd-timesyncd
> timedatectl set-ntp off

Could you tell the most suitable way to do this (modificate rootfs, disable in configuration, set broken config for timesync, disable from console one time, install new systemd without enabled time sync)?

I am using distribution based on rootfs from Colibri-iMX6ULL_Console-Image 2.8b6 with some changes and built Linux Kernel from Source Code.

Thank you.

Hi @Artem,

Please try using timedatectl set-ntp false.

I tried here and I could verify through timedatectl after reboot that the NTP service was disabled after that.

Best regards,
André Curvello

Hi, thanks for the reply.

I tried to use timedatectl set-ntp false but after reboot system time was changed.

root@colibri-imx6ull:~# timedatectl
      Local time: Tue 2021-05-25 07:39:25 UTC
  Universal time: Tue 2021-05-25 07:39:25 UTC
        RTC time: Tue 2021-05-25 07:39:25
       Time zone: Universal (UTC, +0000)
 Network time on: no
NTP synchronized: yes
 RTC in local TZ: no

Best regards, Artem

Have you done a graceful reboot or just pressed a reset button? In a last case changes may not be saved. Please do a reboot command or at least do a sync before HW reset.

I used reboot, but with sync with reset button doesn’t work too

Best regards, Artem

That’s really strange, because testing it here my parameter “NTP synchronized” is “no” after a reboot with timedatectl set-ntp false.

Apart from your main topic, I saw that you are using a really old BSP, 2.8b6.

If possible, I suggest you move to BSP 3.0.4, which is our current Long-Term-Support BSP.

Best regards,
André Curvello

I need to investigate a few conventions (ARP, NDP, and so on) inside virtualbox (operating system: Linux Mint 19.1 Tessa) utilizing wireshark and attempted to incapacitate the “network time control”- synchronization. yuza@VirtualBox:~$ sudo timedatectl set-ntp off && timedatectl status Nearby time: Fri 2019-04-12 09:59:28 CEST General time: Fri 2019-04-12 07:59:28 UTC RTC time: Fri 2019-04-12 07:59:29 Time region: Europe/Vienna (CEST, +0200) Framework clock synchronized: yes systemd-timesyncd.service dynamic: no RTC in neighborhood TZ: no Still, wireshark catches often NTP traffic. I’m mindful of wiresharks catch channel and show channel. By the by, I’m intrigued why I can’t incapacitate NTP utilizing sudo timedatectl set-ntp off?
snaptube vidmate

Sorry, but I don’t understand you question. Which Toradex module you are talking about?