Disable eth store and forward mode


We would like to use jumbo frames to send UDP video stream pacakges at Colibri. Destination is a fixed device and no other switch/router exist.

After some research, found this question, and it directs to NXP forums page. But to patch does not exist.

When checked the NPX forum page, a comment denotes disabling the store-and-forward mode allows bigger frames. After some search at the kernel source, I found this line denotes enables store and forward mode:


Also, I have checked eth KSZ8041NL chip driver, which is located at drivers/net/phy/micrel.c at kernel source, but couldn’t figure out is capable of disabling that mode.

Also, we do not have throuhgput more than 400Mbps limit that noted at ERR004512:

Is it the right way to comment out this line to disable store-and-forward mode ?

How can I disable store-and-forward mode ?


Hello @huseyinkozan ,

Thank you for your patience with this query. Have you perhaps already checked a similiar community thread here:

Other thsn that, I am afraid we don’t have much to add.

Best Regards,

Any updates on this topic from your side, @huseyinkozan?


Sorry for the late response. I have not enough time for this to try. I’ll inform if any progress.

Ok. Thanks for the feedback. We will wait for your answer.