Disable display during uboot

I would like to disable my display as long as uboot is active, because the display isn’t correctly initialized and actually I simply do not need in this stage.
The linux kernel then should initialize the framebuffer and display the splash screen.

How do I disable the display in uboot?

I tried setting CONFIG_VIDEO=n in colibri_imx6_defconfig « configs - u-boot-toradex.git - U-Boot bootloader for Apalis and Colibri modules so the framebuffer/display block in colibri_imx6.h « configs « include - u-boot-toradex.git - U-Boot bootloader for Apalis and Colibri modules gets deactivated

Unfortunately this results into a big compiling error:

| make[1]: Leaving directory '/home/christian/oe-core-2.8b3/build/tmp-glibc/work/colibri_imx6-angstrom-linux-gnueabi/u-boot-toradex/2016.11+gitAUTOINC+aca804c9dd-r0/build/colibri_imx6_defconfig'
| Makefile:150: recipe for target 'sub-make' failed
| make: *** [sub-make] Error 2
| make: Leaving directory '/home/christian/oe-core-2.8b3/build/tmp-glibc/work/colibri_imx6-angstrom-linux-gnueabi/u-boot-toradex/2016.11+gitAUTOINC+aca804c9dd-r0/git'
| ERROR: oe_runmake failed
| WARNING: exit code 1 from a shell command.
| ERROR: Function failed: do_compile (log file is located at /home/christian/oe-core-2.8b3/build/tmp-glibc/work/colibri_imx6-angstrom-linux-gnueabi/u-boot-toradex/2016.11+gitAUTOINC+aca804c9dd-r0/temp/log.do_compile.9532)
ERROR: Task (/home/christian/oe-core-2.8b3/build/../layers/meta-freescale-3rdparty/recipes-bsp/u-boot/u-boot-toradex_2016.11.bb:do_compile) failed with exit code '1'
NOTE: Tasks Summary: Attempted 5209 tasks of which 5202 didn't need to be rerun and 1 failed.
NOTE: Writing buildhistory

Summary: 1 task failed:
  /home/christian/oe-core-2.8b3/build/../layers/meta-freescale-3rdparty/recipes-bsp/u-boot/u-boot-toradex_2016.11.bb:do_compile
Summary: There was 1 WARNING message shown.
Summary: There were 2 ERROR messages shown, returning a non-zero exit code.

What is the correct way to achieve this?

Dear @cheesi,

Try the following change to u-boot as described here: https://community.nxp.com/thread/460796.
The only difference would be the file you are changing would be this: u-boot-toradex/include/configs/colibri_imx6.h. This change seems to work on my end with nothing being displayed while in u-boot.

I hope this helps solve your issue, please let me know how it works out!

Hi

While it works to use =n one usually removes unwanted config lines from a defconfig file. Only if the Kconfig process does by default switch on an option XXXX, one overrides by putting ‘# CONFIG_XXXX is not set’.

Removing CONFIG_VIDEO=y or changing from ‘y’ to ‘n’ compiles for me when compiling standalone. So I guess something went wrong in your integration into OE. Maybe there are some pointers in the referenced log file?

Note that you probably also want to make sure that the backlight is not switched on in U-Boot or your display might show whatever it has in its buffer when you do not provide any Pixelclock/HSync/VSync/Data.
To achieve this you would change the code in the board file here.

Max

From my understanding this would only disable the splash screen - not the whole display. We had some problems during the CE certification with EMC so i would just like to disable the whole display while u-boot is executed. Otherwise I would need to configure the display accordingly in u-boot.

I will try to remove CONFIG_VIDEO from the defconfig file. Maybe that works.

The backlight in the board file shouldn’t be a problem, as it is not included if CONFIG_VIDEO_IPUV3 is not set. And CONFIG_VIDEO_IPUV3 is only set, if CONFIG_VIDEO is set.

These are the modifications in my layer, not very spectacular:

FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"

SRC_URI += "file://0001-Display-adaption.patch \
            file://0002-Removed-tty-from-framebuffer-console.patch \
            file://0003-Set-server-for-tftp-flashing.patch \
            file://0004-Disabled-display-during-bootloader.patch \
           "

The first three patches were made with an older version. Today I recognized that there are new commits, so i discharged my changes from the working folder and pulled the new commits. Maybe this could also be a problem? (However, the other patch worked without any problems, so I don’t assume, that they are the problem)

Okay I did the following now:

  • Cleaned the u-boot-toradex git repo (again)
  • Rewrote all patches with the newest version
  • Removed CONFIG_VIDEO
  • Still get the same error

Now I gathered some new lines from the log, if that helps anything:

/home/christian/oe-core-2.8b3/build/tmp-glibc/work/colibri_imx6-angstrom-linux-gnueabi/u-boot-toradex/2016.11+gitAUTOINC+aca804c9dd-r0/git/scripts/Makefile.build:425: recipe for target 'drivers/video' failed
make[2]: *** [drivers/video] Error 2
/home/christian/oe-core-2.8b3/build/tmp-glibc/work/colibri_imx6-angstrom-linux-gnueabi/u-boot-toradex/2016.11+gitAUTOINC+aca804c9dd-r0/git/Makefile:1233: recipe for target 'drivers' failed
make[1]: *** [drivers] Error 2
   arm-angstrom-linux-gnueabi-ld.bfd     -r -o common/built-in.o common/init/built-in.o common/main.o common/exports.o common/hash.o common/cli_hush.o common/autoboot.o common/board_f.o common/board_r.o common/board_info.o common/bootm.o common/bootm_os.o common/env_attr.o common/env_callback.o common/env_flags.o common/env_mmc.o common/fdt_support.o common/miiphyutil.o common/usb.o common/usb_hub.o common/usb_storage.o common/iomux.o common/flash.o common/splash.o common/menu.o common/usb_kbd.o common/env_common.o common/bouncebuf.o common/console.o common/dlmalloc.o common/malloc_simple.o common/image.o common/image-fdt.o common/image-fit.o common/memsize.o common/stdio.o common/cli_simple.o common/cli.o common/cli_readline.o common/dfu.o common/command.o common/s_record.o common/xyzModem.o 
make[1]: Leaving directory '/home/christian/oe-core-2.8b3/build/tmp-glibc/work/colibri_imx6-angstrom-linux-gnueabi/u-boot-toradex/2016.11+gitAUTOINC+aca804c9dd-r0/build/colibri_imx6_defconfig'

hi @cheesi

Could you share your patches? Where did you remove the CONFIG_VIDEO?
Unfortunately the log you provided is not complete, please share the complete error log?

Best regards, Jaski

hi @jaski.tx !

Thanks for your response. Yes, I removed the CONFIG_VIDEO from the defconfig file. The other patches shouldn’t be the problem, I already tried compile u-boot just with the defconfig patch.

Unfortunately, I currently do not have the log here, but as far as I can remember, the other log message were just compile statements. I only copied the part, where the error occurs.

Currently, I configured the display and removed the splash screen and disabled the backlight which works for now. Tomorrow is our next CE lab test, then I will see, if we need further modifications.

Thanks for your answer. We would need the complete compile log and the patches to analyze this issue.

It is perfect that you found a solution for the moment. Feel free to ask, if you have more questions.