DHCP server on Verdin Eval board Ethernet port 1

I am using Verdin Full eval. board with Latest Torizon Core OS installed on it. I want to enable DHCP server running on 2nd ethernet port of Verdin eval board.

I have followed this “Networking with TorizonCore” article. Special section of WiFi AP, where one create one “*.network” file and drop under /etc/systemd/network directory and restart the systemd-netword service.

I created one for ethernet1 port and restarted the service but NO LUCK on getting DHCP server up and running on that port.

Greetings @dpatel,

I tried this on my side with the following:

  1. Flash a stock TorizonCore image on my Verdin module.
  2. Create a “*.network” file in “/etc/systemd/network”. For a simple DHCP server I used the following file (numeric values are arbitrary, change them to fit your needs):
[Match]
Name=ethernet1

[Network]
Address=192.168.5.1/24
DHCPServer=true

[DHCPServer]
PoolOffset=10
PoolSize=20

  1. While it may not be needed disable NetworkManager with sudo systemctl stop NetworkManager. There have been cases in the past where networkd can conflict with NetworkManager.
  2. I ran sudo systemctl restart systemd-networkd so that the network file would take effect.
  3. I then setup a completely separate toradex module and connected it’s ethernet to the Verdin module running the DHCP server.
  4. I observed the ethernet interface on the separate toradex module. I can see it now has an IP address served to it, in the “192.168.5.0” subnet which matches what is in the network file.

If you’re still having issues, possibly it’s not on the DHCP server side but on the client side.

Best Regards,
Jeremias