Device doesn't allow deleting registry key that was previously added


To test a device driver that I am working on, I added a registry key to the HKLM\Drivers\BuiltIn.

I want to delete this registry key now. But when I try to delete I get the error: Can’t query key 'Drivers\BultIn.

I renamed my registry key to some other name and then deleted it this time it worked, saved the registry and restarted the system. Yet after the boot up my original registry key showed up under the Drivers\BuiltIn.

I also tried Clear registry option yet after resetting the board my registry was there at the same location.

Dear @kapeed
There’s a number of possible reasons for this behavior.

  1. You didn’t mention which image version you are using. Please make sure to use the latest one.
  2. There’s a typo in your error message ( Can't query key 'Drivers\BultIn instead of 'Drivers\BuiltIn.
    In case the same typo is in your code, it explains the error.
  3. There were registry editor versions which wrongly showed such an error, even though the operation was successful. To be sure, close the registry editor and restart it to verify that the delete operation was not done.
  4. If the registry key is still in use, it cannot be deleted.

The “clear registry” operation will reset the registry to factory defaults in all cases. But if you do a “save registry” between “clear registry” and reboot, then the clear operation has no effect.

If these hints don’t solve the problem, please provide exact instructions (which tools including versions did you use, which key names, …) to enable us to reproduce your problem here.

Regards, Andy