/dev/ttyRPMSG0 is not visible after build and flash of Linux 2.8 on imx7

Linux 2.8 flashed with your original flash image: Colibri-iMX7_LXDE-Image_2.8b6.184-20190401.tar.bz2 worked. The rpmsg device was operational. /dev/ttyRPMSG0 was visible and running.

I loaded from git: colibri-imx7_lxde-image-tezi_2.8b6.184-20190401.tar
I executed: make colibri_imx7_defconfig
I built successfully. Merged zImage into the volume used by UBoot to flash the iMX7.
Linux up and running.

From dmesg:

MU is ready for cross core communication!
imx rpmsg driver is registered
[FAILED] Failed to start Load Kernel Modules

Running systemctl status systemd-modules-load.service didn’t say explicitly what is wrong.

Am I missing some step in the build process?

The full dmesg

link text

also built modules, fixing Load kernel modules failure.

modprobe imx_rpmsg_tty returns nothing

but still no /dev/ttyRPMSG0

It was not obvious that the freeRTOS side of rpmsg must be up and running first to successfully install the module for rpmsg and see the mount in /dev

Perfect that it works. Thanks for the feedback.