Debugging Error "Server Misbehaving"

For some reason after flashing a new image to my board, I’m getting the following error when I try to debug:

 *  Executing task: DOCKER_HOST= LOCAL_REGISTRY= TAG=arm GPU= docker compose -p torizon up -d autofilteringfixture2-debug 

WARN[0000] The "DOCKER_LOGIN" variable is not set. Defaulting to a blank string. 
WARN[0000] /home/lukevizma/AutoFilteringFixture2/docker-compose.yml: `version` is obsolete 
[+] Running 1/1
 ✘ weston Error Get "": dial ...               0.3s 
Error response from daemon: Get "": dial tcp: lookup on server misbehaving

 *  The terminal process "/usr/bin/bash '-c', 'DOCKER_HOST= LOCAL_REGISTRY= TAG=arm GPU= docker compose -p torizon up -d autofilteringfixture2-debug'" terminated with exit code: 18. 
 *  Terminal will be reused by tasks, press any key to close it. 

I get the same error when I try to run:

docker pull torizon/weston:$CT_TAG_WESTON

I’ve tried a handful of the proposed fixes from here, but with no luck.

To elaborate, I’ve tried changing the nameserver in the registry container, adding the predefined IP in /etc/resolv.conf to the insecure registries in /etc/docker/daemon.json on the board, and changing my DNS server as proposed in the link.

What am I missing?

Apalis iMX6 Quad 2GB IT V1.1Y
Ixora Carrier Board V1.3A
Torizon, using Qt C++/QML Template
Host Machine: Windows, VS Code w/ Torizon IDE Extension 2

Hey @lvizzy,

It’s common to see part of that error when the IP host address is incorrect in the /etc/docker/daemon.json file. A quick solution is disconnect the device and reconnect it to the extensions. This should auto load the file again.

“insecure-registries” : [“”]

The second part looks like your docker-compose.yml file should be a docker-compose.yaml file if possible.


Hey @eric.tx,

Disconnecting and reconnecting doesn’t solve the issue, and neither does manually setting the insecure registries to the IP you mentioned. (By the way, why do you recommend to set it to I thought it was supposed to be my host computer IP?)

Do you have any other thoughts?

Also when I change the docker-compose to a .yaml, the build process yells at me… is it necessary to change it to .yaml?

Hey @lvizzy,

You are correct on the IP, it should be your host. The IP shown is just an example for identifying format.

This looks like a connection to the docker registry error, do you have any firewalls setup? Or hosting the registry private?

Within your docker-compose file, do you have a property " version" listed? This is a depreciated property and shouldn’t be used.

Also, can you post your full terminal logs?


Turns out the problem is that I’m using two networks, one connected to internet and one not, that were accidentally sharing the same network ID. So the build process couldn’t find the remote registry. When I just connect my SoM/host PC to the internet-enabled network, it’s able to pull the container.

Thanks for the help!