Data Abort Exception in NK.exe

Hi all,

I get the following exception if I try to debug my application:

Exception 'Raised Exception' (0x406d1388): Thread-Id=04a9036a(pth=b10d7000), Proc-Id=04ef0362(pprc=b10bc858) 'msvsmon.exe', VM-active=04ef0362(pprc=b10bc858) 'msvsmon.exe'
PC=40023127(coredll.dll+0x00013127) RA=801a0a1f(kernel.dll+0x00006a1f) SP=00b4fd68, BVA=41a57908
Exception 'Data Abort'(4) Thread-Id=0192001a(pth=b101a5f8) PC=ef3d61b1 BVA=002c5000, dwInfo = 00002804
 R0=00000000  R1=00000000  R2=00000000  R3=00010000
 R4=00000001  R5=00000000  R6=001e8480  R7=00000001
 R8=00000000  R9=00000001 R10=ef3d87f8 R11=bd8bfb88
R12=b503c7d8  SP=bd8bfb78  Lr=ef3d5fd1 PC=ef3d61b1, Psr=4000003f
Exception 'Data Abort'(4) Thread-Id=0192001a(pth=ffffc588) PC=801906b9 BVA=002c5000, dwInfo = 00002804
 R0=002c5000  R1=00001000  R2=00000020  R3=00008000
 R4=00000006  R5=81f24ae0  R6=00001000  R7=b101a5f8
 R8=002c5000  R9=00000001 R10=00000001 R11=ffffc770
R12=81f3a014  SP=ffffc758  Lr=80190445 PC=801906b9, Psr=800001b3
Exception 'Data Abort' (0x4): Thread-Id=0192001a(pth=b101a5f8), Proc-Id=00400002(pprc=81f3cae0) 'NK.EXE', VM-active=04ef0362(pprc=b10bc858) 'msvsmon.exe'
PC=801906b9(NK.EXE+0x000106b9) RA=80190445(NK.EXE+0x00010445) SP=ffffc758, BVA=00000000

I do not even reach the first line of my program.

This problem exists in 1.1b4 and 1.1. With 1.1b2 debugging is no problem.

I also tested some demo projects you provide and they are ok with 1.1 and 1.1b4.
Only my application crashes since 1.1b4.

Can you help solving this problem?

Kind regards,

Dear @Kuzco,

  1. Did you able to debug hello world console application? I have tried it, I am able to debug it with 1.1b4.
  2. Could you please attach your project here, let me try to reproduce the issue on our end.
  3. Are you VS2015 or VS2013? I tested it using VS2015 and also attached visual studio updates screenshot for your comparison.

Dear raja.tx, thanks for your answer.

  1. I’m able to debug some test projects (Can_Demo, CoProc_Demo, Rpmsg_Demo, …) with 1.1 and 1.1b4.

  2. I’m sorry, but I can’t upload the project. It’s a software which is distributed from a third party company. We bought a license and we are forbidden to share the code.

  3. I use VS2013. I also uploaded a screenshot here.

From 1.1b2 to 1.1b4 you added the feature for multicore support. As I said I can debug the application using 1.1b2.

Is it possible that the multicore support makes trouble?

Dear @raja.tx,

I uploaded a project here.
If pex.mpenable is set to 1 I get with this project/project settings the data abort exception.
If pex.mpenable is disabled, everything is fine.

Tested with:

  • VS2013
  • Eboot = v1.1
  • Image = v1.1
  • Modul = Colibri IMX7D
  • Colibri Eval Board Rev. 3.20


I just looked at this project of yours. How do you create it?
This is missing alot of information from vcxproj.

I attached the template file you can use to compare it.

Hi @luka.tx

I haven’t create the project. This project was created by a third party and delivered to us. As I said if I disable multicore support I don’t get an exception. Don’t know what to change in the settings of the project that the exception do not occur.


I did not check every setting of your project file but seems that something is missing there. You will have to go step by step and compare settings. You can also compare settings with out demos to see where the difference comes from.

Dear @raja.tx
do you have any solution for the problem?

I’ve tried the steps @luka.tx have suggested and adjusted the project settings.
But the problem exists furthermore.

During our tests we have some problems with the ethernet connection.
The connection is not stable enough. We often lose the connection to the iMX7.

Is something known in this regard?

Thanks for answer


Dear @kuzco,

We have observed a similar issue during our development and created a ticket to work on that. @luka.tx is on vacation, Once he back and we will discuss internally and get back to you before the end of the next week.
Please continue your development with bearing this issue.

@raja.tx thanks for your answer. I will wait.

Dear @raja.tx,

do you have some new informations about the issue?
Or can you describe the issue you found a bit more?
Our customer is asking and I’m not able to answer.

Thanks and best regards

Dear @kuzco,

Thank you for your patience. Our developer is back and is planning to look initial study of the issue and let you know some update before the end of this week.

We tried to debug a modified version of the i2cdemo.
While stepping, sometimes CE7 V1.1 crashed with a data abort in NK.exe.
This also happened (but not always) when setting a breakpoint in Visual Studio during a debug session.

Let us know if it is very urgent for you.

Dear @Kuzco,

Could you please wait for few days, I need to spend some time on this and get back to you.
If you are guessing multicore addition would be the problem, you can disable that by going into bootloader command prompt and disabling pex.mpenable and let us know the feedback.

BootLoader Configuration:

C) Clear Flash Registry
X) Enter CommandPrompt Mode
D) Download image to RAM now
F) Download image to FLASH now
L) Launch existing flash resident image now

Enter your selection: x

>set pex.mpenable 0


Dear @raja.tx,

thanks for this hint.

I disabled multicore support in bootloader as you suggested and now I can debug again.
No exception is thrown.

Of course you can spend some time for this problem.
The workaround at the moment is okay for me.
Maybe this is a clue to solving the problem.

Kind regards,


Dear @kuzco,

We found the problem and fixed it on the WEC7. We would like to build the same for WEC2013 and share the preliminary release with you tomorrow.

Dear @raja.tx,

good. If I have the preliminary release version I will test it with my project.

Dear @kuzco,

Thank you for your patience.

We have released 1.2 b2 image recently. Could you please try that and let us know if still see the issue.

Dear @raja.tx,

I try the image since beginning of this week.
Until now I didn’t get a error.
Seems working.
Thank you very much for your time you spent on that issue.

Best regards