Dahlia/Verdin 8M plus refuse to boot with USB-C debug connected to workstation


I was happy user of Dahlia/Verdin combo last year, used that to created customized Linux distro for the customer. Due to switching between projects I’ve not used combo for last half of year. Now I’ve taken it from my storage box in my dry office environment and to my surprise the board is not working well anymore.

What I connected:

  • PSU 12V 1.5A
  • RJ45 ethernet cable
  • USB-C debug port with other end connected to my workstation where minicom is running and waiting on /dev/ttyUSB0

The issue manifest as:

  • I push power button and board stays on for ~1second. Then LEDs die out and nothing happen.

By a luck I’ve found out that if I unconnect USB-C debug, then board boots to the Toradex internal distro.
However when I’ve plugged USB-C debug in again, it still stays on. But once I run either screen or minicom in an attempt to connected to provided serial the board immediately switch off.

I tested this scenario with 1 Linux workstation and 1 mac mini running macOS. I also tested 3 different USB-C cables. On Linux I tested minicom and screen. On macOS only screen was used. The end effect is still the same.

My question is: is this a known issue? If so I would appreciate URL/reference to how to solve it. If not, is there any hope to get debug USB-C console working again?


Hardware versions, numbers shown on the original invoice:

  • Verdin iMX8M Plus Quad 4GB IT V1.1A
  • Dahlia Carrier Board with HDMI Adapter V1.1C

Hello @kgardas ,

Try to connect to /dev/ttyUSB3, it should work.

Best regards,

@josep.tx Thanks a lot for your fast response. Indeed, this is exactly what’s needed to be done. I see u-boot, linux boot and most importantly board stays up and running well. Thanks for your support!