Dahlia sound device?


When originally developing on the Verdin full size carrier board I could just put --device=/dev/snd on the docker run command line and get access to the sound. It appears the Dahlia doesn’t automagically map the sound hardware to /dev/snd though the device is listed in /dev with the Torizon Core with demos installed.

I see some adc devices that look suspicious but thought I would ask for the correct device.


Okay, I burned my Sunday trying to shoot this. I don’t speak hardware and I cannot find any doc on the site about how to enable the sound/audio on the Dahlia carrier. No matter what I do I only see


which is not correct. There should be a group of them if this carrier behaves the way the full sized Verdin did. This code worked perfectly on there running under a stripped down Torizon Core. I don’t have the full sized card connected right now. (Supply issues, only enough pieces and parts to use one.) It’s possible that something changed for the worse in Torizon Core and now Audio isn’t enabled by default.

I do have the 10.1 touch screen connected and as such, per Web site instructions, changed overlays.txt to have the following:

fdt_overlays=touch-atmel-mxt_overlay.dtbo verdin-imx8mp_sn65dsi84-lt170410_overlay.dtbo verdin-imx8mp_sn65dsi84_overlay.dtbo

Being software and not hardware, there are two things that bug me in the Dahlia data sheet.

That makes it sound like “if the Carrier is configured for CAN, Audio no have power.”
Again, I’m not a hardware guy. I don’t know how to check if CAN is even configured on this board. It was sent to me the way it was sent to me.

The other potential Red Herring is as follows:

To a software guy that sounds like a super secret configuration bit must be flipped somewhere.

At any rate, I need to get this working on the Dahlia carrier now. It worked clean and nice on the Verdin but this smaller carrier is the current direction.


One more set of datapoints. When I launch with the following as always worked on the big board a month or so ago, I get the “no such file/device” message trying to open the sound device. I still only see one sound device where on the big board I saw quite a few.

docker run --rm -d --name=BoardVerification --device=/dev/verdin-uart1 --device=/dev/verdin-uart2 --device=/dev/snd --mount type=bind,source=/media,target=/media/torizon,bind-propagation=shared -v /tmp:/tmp -v /var/run/dbus:/var/run/dbus -v /dev/galcore:/dev/galcore --device-cgroup-rule='c 199:* rmw' seasonedgeek/board_verification_container

If I use this command with the --privileged qualifier I can access the device just fine. No sound comes out, but I can access device.

docker run --rm -d --name=BoardVerification --device=/dev/verdin-uart1 --device=/dev/verdin-uart2 --device=/dev/snd --privileged --mount type=bind,source=/media,target=/media/torizon,bind-propagation=shared -v /tmp:/tmp -v /var/run/dbus:/var/run/dbus -v /dev/galcore:/dev/galcore --device-cgroup-rule='c 199:* rmw' seasonedgeek/board_verification_container

If I take off the LVDS adapter, I no longer need any kind of priv to access the device.

Something is dramatically different between the Dahlia and the full sized carrier. Either that or someone has really redone these device group rules.

Need sound to come out.

Please assist. I’m on my third day of trying to make what used to work work.


Even aplay produces no sound

It hangs trying to write for quite a while then errors out.