CUPS printing error

Whenever I try to print a PDF file using the lp command or from the program I wrote which uses the CUPS API, I get the following error upon checking the current state of the print job using lpstat -l:

C331-108 iris 420864 Tue Jan 25 20:06:31 2022
Status: loadFilename failed: open no: No such file or directory
Alerts: job-completed-with-errors
queued for C331

I’ve also checked the log file located in /var/log/cups/error_log and it prints out the same error as shown below:

[Job 115] loadFilename failed: open no: No such file or directory
[Job 115] Input is empty, outputting empty file.
[Job 115] PID 895 (/usr/libexec/cups/filter/pdftops) exited with no errors.
[Job 115] PID 894 (/usr/libexec/cups/filter/pdftopdf) stopped with status 1.

I don’t understand why I’m getting this error because I’ve tried to do the exact same thing in another Linux machine and there everything works correctly and I’m able to print a pdf file.

cups version 2.2.12
cups-filters 1.27.2

Hi @edmon ,

Thanks for contacting Toradex Community.

Regarding issue can you please share more details as below

  • BSP Version, Module version and Baseboard version.

  • What are the packages added in order to get CUPS running.

IMAGE_INSTALL_append = "cups cups-doc cups-lib cups-libimage cups-filters hplip hplip-ppd hplip-cups hplip-backend hplip-filter"
  • Printer make with which you are testing.

Finally output of below commands
lpinfo -v
lpinfo -m
lpstat -d

Best Regards
Ritesh Kumar

Hello @ritesh.tx ,

  • We’re actually using a yocto based linux system that we created on our own. Regarding the module version, it’s Colibri iMX6s 256MB Version 1.1a.

IMAGE_INSTALL_append = " packagegroup-printing"

  • The printer used is OKI C331dn

  • lpinfo -v

network ipps
file cups-brf:/
network http
network beh
network lpd
network ipp
network https
network socket
direct usb://OKI%20DATA%20CORP/C331?serial=AK43026147

  • lpinfo -m

lsb/usr/cupsfilters/Fuji_Xerox-DocuPrint_CM305_df-PDF.ppd Fuji Xerox
drv:///sample.drv/dymo.ppd Dymo Label Printer
drv:///sample.drv/epson9.ppd Epson 9-Pin Series
drv:///sample.drv/epson24.ppd Epson 24-Pin Series
drv:///generic-brf.drv/gen-brf.ppd Generic Braille embosser, 1.0
drv:///cupsfilters.drv/pwgrast.ppd Generic IPP Everywhere Printer
drv:///sample.drv/generpcl.ppd Generic PCL Laser Printer
lsb/usr/cupsfilters/Generic-PDF_Printer-PDF.ppd Generic PDF Printer
drv:///sample.drv/generic.ppd Generic PostScript Printer
drv:///cupsfilters.drv/textonly.ppd Generic Text-Only Printer
drv:///generic-ubrl.drv/gen-ubrl.ppd Generic UBRL generator, 1.0
lsb/usr/cupsfilters/HP-Color_LaserJet_CM3530_MFP-PDF.ppd HP Color LaserJet CM3530 MFP PDF
lsb/usr/cupsfilters/pxlcolor.ppd HP Color LaserJet Series PCL 6 CUPS
drv:///cupsfilters.drv/dsgnjt600pcl.ppd HP DesignJet 600 pcl, 1.0
drv:///cupsfilters.drv/dsgnjt750cpcl.ppd HP DesignJet 750c pcl, 1.0
drv:///cupsfilters.drv/dsgnjt1050cpcl.ppd HP DesignJet 1050c pcl, 1.0
drv:///cupsfilters.drv/dsgnjt4000pcl.ppd HP DesignJet 4000 pcl, 1.0
drv:///cupsfilters.drv/dsgnjtt790pcl.ppd HP DesignJet T790 pcl, 1.0
drv:///cupsfilters.drv/dsgnjtt1100pcl.ppd HP DesignJet T1100 pcl, 1.0
drv:///sample.drv/deskjet.ppd HP DeskJet Series
drv:///sample.drv/laserjet.ppd HP LaserJet Series PCL 4/5
lsb/usr/cupsfilters/pxlmono.ppd HP LaserJet Series PCL 6 CUPS
drv:///indexv3.drv/i4waves3.ppd Index 4-Waves PRO, 1.0
drv:///indexv3.drv/i4x4pro3.ppd Index 4x4 PRO V3, 1.0
drv:///indexv3.drv/ibasicd3.ppd Index Basic-D V3, 1.0
drv:///indexv4.drv/ibasicd4.ppd Index Basic-D V4/V5, 1.0
drv:///indexv3.drv/ibasics3.ppd Index Basic-S V3, 1.0
drv:///indexv4.drv/ibasics4.ppd Index Basic-S V4/V5, 1.0
drv:///indexv4.drv/ibrlbox4.ppd Index Braille Box V4/V5, 1.0
drv:///indexv3.drv/ieveres3.ppd Index Everest-D V3, 1.0
drv:///indexv4.drv/ieveres4.ppd Index Everest-D V4/V5, 1.0
drv:///sample.drv/intelbar.ppd Intellitech IntelliBar Label Printer, 2.1
drv:///sample.drv/okidata9.ppd Oki 9-Pin Series
drv:///sample.drv/okidat24.ppd Oki 24-Pin Series raw Raw Queue
lsb/usr/cupsfilters/Ricoh-PDF_Printer-PDF.ppd Ricoh PDF Printer
drv:///sample.drv/zebracpl.ppd Zebra CPCL Label Printer
drv:///sample.drv/zebraep1.ppd Zebra EPL1 Label Printer
drv:///sample.drv/zebraep2.ppd Zebra EPL2 Label Printer
drv:///sample.drv/zebra.ppd Zebra ZPL Label Printer
everywhere IPP Everywhere

  • lpstat -p -d

printer C331 is idle. enabled since Tue Jan 25 20:22:40 2022
no system default destination


Hi @edmon ,

Did you managed to get it working. Logs looks fine to me.
What other system do you refer here. Is it arm based or x86 system? I would suggest if possible please check with different make of printer to isolate issue.

Best Regards
Ritesh Kumar

Hello @ritesh.tx ,

I already managed to solve the problem and get it working. Updating the qpdf version fixed the issue for me as answered by someone in this issue I posted in github. Thanks