Create SDK with SDKMACHINE="x86_64-mingw32" fails

Hello,

I’m using a Verdin iMX8M Mini with BSP v5.6 and want to develop a Qt-application with the Qt Creator on a Windows machine.

Therefore I followed these steps to build the SDK:

  1. download the mingw layer:
$ git clone git://git.yoctoproject.org/meta-mingw -b dunfell
  1. add the layer to my bblayers.conf
  2. add the following lines to my local.conf:
SDKMACHINE = "x86_64-mingw32"
SDK_ARCHIVE_TYPE = "zip"
  1. build the sdk with
$ bitbake tdx-reference-multimedia-image -k -c populate_sdk

Unfortunately the build fails for several packages, please see the attached
log file (92.4 KB).

Since this bug report exists, is it even possible? ([QTBUG-71199] bitbake meta-toolchain-qt5 fails for SDKMACHINE="x86_64-mingw32" - Qt Bug Tracker)

Or do I have to wait for Qt6 support? (Qt 6 in OpenEmbedded and Yocto)

With best regards,
Markus

Hi @Mowlwurf !

From the bug tracker link that you shared, someone commented that meta-qt5 doesn’t support MinGW by itself, and to add MinGW support, one should add meta-boot2qt for that.

Have you tried it?

Best regards,

Hi Henrique,

yes I tried it, but the verdin iMX8M Mini isn’t supported by the layer.

Additionally, we want to use the Qt open source license and Boot 2 Qt is for what I know only part of the commercial license.

Maybe the only solution is, to use the SDK for Linux in a virtual machine and try again, when Qt 6 ist used by the BSP.

Best regards,
Markus

Hi @Mowlwurf,

I’m afraid that it is the only solution right now, based on the links you shared with us.
One thing that might help you is using the Windows Subsystem for Linux by Microsoft (WSL2) or perhaps building your image inside a docker container that runs Ubuntu.
So, if this works, you could avoid using a virtual machine.

Best regards,
Hiago.