Continuous restart during booting (Restarts at MMC)

Hi there,

I have IMX8QM connected on an Ixora Carrier board V1.2. It was running for some time, but now for some reasons it cannot boot up and reboots continuously with the following logs I collected from the serial port:
image

Do you know what is going on?
Thanks
Samir

Hello @hajili ,
How is your setup powered?
Could you please share with us the output of tdx-info? Getting Device Information with Tdx-Info | Toradex Developer Center
Have you tried putting it in recovery mode and reflashing it?

Best regards,
Josep

Hi Josep,

this was the latest tdx-info that I obtained recently.

Software summary
------------------------------------------------------------
Bootloader:               U-Boot
Kernel version:           5.4.193-5.7.2+git.b60d3160fd04 #1-TorizonCore SMP PREEMPT Fri Dec 23 15:47:24 UTC 2022
Kernel command line:      pci=nomsi root=LABEL=otaroot rootfstype=ext4 quiet logo.nologo vt.global_cursor_default=0 plymouth.ignore-serial-consoles splash fbcon=map:3 ostree=/ostree/boot.0/torizon/5e343924059c09b700803ca1ebf267b64249ec939502622cc0c4d4fc97b304c4/0
Distro name:              NAME="TorizonCore"
Distro version:           VERSION_ID=5.7.2-build.20
Hostname:                 apalis-imx8-07278691
------------------------------------------------------------

Hardware info
------------------------------------------------------------
HW model:                 Toradex Apalis iMX8QM V1.1 on Apalis Ixora V1.2 Carrier Board
Toradex version:          0037 V1.1E
Serial number:            07278691
Processor arch:           aarch64
------------------------------------------------------------

I am powering with 12V DC using 12V Barrel Jack adapter. Before, the SBC was working properly. Reflashing would be the next step if I can’t solve it.

But, it looks like u-boot is not loading, there is a sudden restart, before u-boot. Or not true?

Thanks

Hello @hajili ,

Seems that u-boot is loading to some extent. But our first recommendation would be to enter recovery mode and reflash the module.

Best regards,
Josep

Hi Josep,

I keep the recovery pins shorted as described in the instructions, however, after removing the jumper to unshort them (after 6 sec), it goes back to keep restarting with the same logs from the thread.

The recovery bat file do not start tried also on linux.

I do not hear the OTG USB connection notification sound from windows

any ideas?

Thanks
Samir

Hello @hajili ,
In that case it could be a damaged module. You can start an RMA process here:

Best regards,
Josep

1 Like