Connman-properties error on Apalis iMX6

I have been attempting to learn kernel building on an Apalis iMX6 Ixora and add the ath10k driver. After trying to rebuild the kernel from source, following your instructions, I was unable to get things working. I then moved to Yocto where, by all indications I can see, was able to build a new stock image and load it to the target. One problem I had before the Yocto build was conmann-properties has an error:

“Error getting services: The namenet.connman was not provided by any .service files”.

The connection preferences window does open on the target but does not show any connections. I’ve reset the environment to it’s defaults. Are there other default resets I need to perform? I’m assuming this issue is on the target and not the Yocto build because it was there before.


This is really expected to all work fine. Please also check the following article on our developer website. If you keep having issues I recommend first trying the manual procedure with our stock demo image and posting console output should you still face issues there. I would also first try without Wi-Fi and only add it in a second step as outlined here.

This turned out to be caused by using a network switch. I replaced the switch with a router and the problem went away. I’m not going to dig into this any further as it’s working and I won’t be using a switch in my application.

Several of our engineers including me are actually using switches with it all the time so I doubt this being the real issue. Would be interesting to find out what exactly is failing in your case.

That said I have seen connman segfaulting at times albeit very rarely but so far never managed to really get down to what is causing it resp. what exactly goes wrong as every time I tried to dig deeper it suddenly worked again.