Configure Idle state of MOSI line of the SPI to be 0 instead of 1

Hi,
By some reason the MOSI signal from the SPI always stays and remains to HI 1 state between every byte transfer via the SPI. However we use that signal for other function (conversion start) to ADC not just as MOSI signal and that default idle state HI is big problem.

Is there any way to configure MOSI idle state to be 0 between transfers? Device tree or some other SPI configuration that could define its state to idle 0.

Thanks,
BR

Hi

I think that the ECSPIx_CONFIGREG, field DATA_CTL allows to configure MOSI to go to 0 in idle. But the linux driver does not have an interface to change the setting in any way, particularly not from the device tree.
So you would need to add what you need to the driver.

Max

Thanks,

What you will recommend, to update the SPI driver source into the Yocto environment and rerun bitbake? Will it be driver recompilation in every build or it will simply overwrite my changes and get it form the git repo.

Thanks,

Hi

Please have a look at the following blog post:

https://www.toradex.com/blog/patching-kernel-in-openembedded

Max