Configration RAC

Hello Toradex team,

I hope you are all doing great! And thank you for your support.

Hardware:

uname:

  • Linux verdin-imx8mp-14777482 5.15.129-6.4.0+git.67c3153d20ff #1-TorizonCore SMP PREEMPT Wed Sep 27 12:30:36 UTC 2023 aarch64 aarch64 aarch64 GNU/Linux

Images tested:

  • torizon-core-docker-verdin-imx8mp-Tezi_6.4.0+build.5.tar (STABLE Release)

Guest OS:

  • macOS (M1 Pro ARM64)
  • Linux ubuntu (VM x86_64)

Issue:
We are using the beta feature remote-access to be able to debug our hardware on the fly. The service works great but there is a lack of customization. We realize that the service itself use a lots of data (you can see the log of
2024.01.23.11.02 - WireShark Remote access only.csv (192.5 KB)) and we don’t have the possibility to tweak some parameters.

So my question is the following, is there the possibility to change some parameters to reduce the amount of ping (~3 seconds) to something more realistic that fit the limited constraint of a cellular connection ? I realize that the experience will not be the same but that something we are ready to sacrifice.

Best regards,
M

Hello @unablesalt .

Could you please share with us the actual Wireshark trace file?
You can send it to share.toradex.com and then send us the generated link via email, mentioning this ticket.

Best regards,
Josep

Greetings @unablesalt,

From what I understand you want to reduce the frequency with which rac polls the server, yes?

This should be doable. The rac source repo can be found here: GitHub - toradex/torizon-rac: Remote access client for Torizon

The README describes the available config options. In particular you’d probably be interested in poll_timeout. The config file on our systems is located at /etc/rac/client.toml. Once you modify this, you should restart the service with sudo systemctl restart remote-access to have any changes take effect.

Side-note the syntax for setting poll_timeout is a bit odd. For example if you want to set a polling of 60 seconds it should look like this:

poll_timeout= { secs = 60, nanos = 0 }

Best Regards,
Jeremias

Hello @jeremias.tx,

Thank you for your answer, that’s exactly what I had in mind. I already change poll_timeout to a bigger value that fits our need and it’s working as expected!

I can mark this issue as solved.

Best regards,
M

Glad we were able to assist.