Colibri VF50 bootloader failed

I got a problem with my new VF50, The board version is V1.2A and carrier board is Iris. The vf50 I got last week is brand new and we were planing to use embedded Qt and Linux on it. I found it had eboot on it and then I followed the instruction and try to flash in the uboot. I followed the “Flashing Embedded Linux to Vybrid Modules - Flashing using Eboot (WinCE Toradex Bootloader)” and after execute command eraseflash 0x00180000 0x00080000 successfully, command flashloader colibri_vf/u-boot-nand.imx failed. I tried flashloader u-boot-nand.imx too and it didn’t work neither.

I’m not completely sure what I did after this and then after power cycle, the debug port shows nothing, even no eboot info. I tried it several times and I tried the recovery mode. I followed the “VFxx Recovery Mode” instructions and in Linux, it shows:

parse vf_flash/vybrid_usb_work.conf
starting associating phase…
magic missmatch, response was 0x00000000

In windows imx_uart.exe COMX: .\vybrid_uboot.conf command also didn’t work. I looked into the community posts and shorten CTS/RTS, tried both recovery mode jumper on module and carrier board, but there is no luck. So I don’t know what I can do now or it is completely dead? I noticed that the power light on the carrier board is still on.

If anyone can help me with this issue, I’d be really appreciated.


can you replace vybrid_uboot.conf with this one →

I just tried using recovery mode and it passed successfully.

Hi, Thanks a lot for the answer, and I tried your file, there is still no luck. imx_uart.exe COMX: .\vybrid_uboot.conf command just stuck at starting associating phase. Is there any indication whether the device is in recovery mode? I tried several times but I’m not sure the device is in recovery mode or not.

Does same happen if you want to recover EBOOT? You can also try adding parameter --no-rtscts to imx_uart.exe

imx_uart.exe --no-rtscts COMX: .\vybrid_uboot.conf

What is the number of the COM port you have? Do you have USB to Serial?

I tried --no-rtscts option, but it is the same, nothing happened. I also tried eboot, same no respond. The COM port I have it COM4, it is a USB FTDI RS232 cable. I’m sure the cable is OK since it had output before the board stop respond.

@Chaoyong, when recovering from Linux, did you try to he -n option for no RTS/CTS? Also do you have a serial terminal open while doing recovery? This is often an issue. Try closing all other terminal sessions on the TTY device while using recovery mode. Then afterward, assuming the recovery mode pushes the bootloader successfully, open the terminal to access the bootloader prompt.

I tried the recovering in Linux too, it is still no go. It always shows
parse vf_flash/vybrid_usb_work.conf starting associating phase… magic missmatch, response was 0x00000000

I have no other terminal attached and also used the -n option. I used the command ./ -n -d /dev/ttyUSB0

I also tried to connect RTS/CTS and run the command without -n option, same story:(

Hey I am facing the exact same problem. Did you ever get board working?

If you get “magic missmatch, response was 0x00000000” it means that the module did not answer at all. This either happens because hardware handshaking is not set up correctly or the module is not in recovery mode.

When using the Evaluation Board, I recommend the following process:

  1. Power off the board
  2. Press the recovery mode button and keep it pressed
  3. Power on the board (keep the recovery mode button pressed)
  4. After 1s, release the recovery mode button

WIth Iris, just make sure to populate the jumper before powering the module. When using X13, you typically have RTS/CTS, hence the -n parameter must not be used.