Colibri T30 Linux V2.5&2.6 stuck in Lock Screen

Flashed Linux image with v2.6 also tried v2.5 and issued setenv vidargs ‘video=tegrafb0:1280x1024-16@60’ and savenv booted to desktop normally and added java path to /etc/profile after reboot not able to login to Desktop getting Lock screen with 3 users : root, syste-journal-- & other. None of them log’s in. root will blink screen and comes back to lock again.
Key shortcuts (ctrl+F1/alt+F1) not worked. Kindly assist.
Using Iris board & Colibri T30 .


Can you share details on which jdk do you use and how exactly did you add it to the image? What exact change you made to /etc/profile to add the java path? I tried with the oracle jdk 8u91 version on Colibri T30 with 2.6 Beta 2.

mkdir /opt
tar -xvf jdk-8u91-linux-arm32-vfp-hflt.tar.gz -C /opt/
echo 'export PATH=/opt/jdk1.8.0_91/bin:$PATH' >> /etc/profile
echo 'export JAVA_HOME=/opt/jdk1.8.0_91' >> /etc/profile

After reboot from our regular LXDE desktop as well as command line, desktop boots as usual without any problems with login.

root@colibri-t30:~# java -version
java version "1.8.0_91"
Java(TM) SE Runtime Environment (build 1.8.0_91-b14)
Java HotSpot(TM) Client VM (build 25.91-b14, mixed mode)

There is no restriction on a using text editor like vi on /etc/profile.

exactly the same way followed. Except Only jdk is extracted to /var/
It worked well for first boot. After rebooting is the problem arrived.
After echo ‘export PATH=/opt/jdk1.8.0_91/bin:$PATH’ >> /etc/profile & echo ‘export JAVA_HOME=/opt/jdk1.8.0_91’ >> /etc/profile used vi to verify. Is there any restrictions to not use text editor on /etc/profile ?