Colibri t30 emmcboot failed

I have de following error on booting:

Colibri T30 # reset
resetting ...

U-Boot SPL 2015.04 (Mar 31 2016 - 01:14:11)

U-Boot 2015.04 (Mar 31 2016 - 01:14:11)

DRAM:  1 GiB
MMC:   Tegra SD/MMC: 0, Tegra SD/MMC: 1
In:    serial
Out:   lcd
Err:   lcd
Model: Toradex Colibri T30 1GB V1.1E, Serial# 02644748
Net:   Net Initialization Skipped
No ethernet found.
Hit any key to stop autoboot:  1  0 
Booting from internal eMMC chip...
reading tegra30-colibri-eval-v3.dtb
** Unable to read file tegra30-colibri-eval-v3.dtb **
reading uImage
4300520 bytes read in 133 ms (30.8 MiB/s)
## Booting kernel from Legacy Image at 81000000 ...
   Image Name:   Linux-3.1.10-gd2f0387-dirty
   Image Type:   ARM Linux Kernel Image (uncompressed)
   Data Size:    4300456 Bytes = 4.1 MiB
   Load Address: 80008000
   Entry Point:  80008000
   Verifying Checksum ... Bad Data CRC
ERROR: can't get kernel image!

emmcboot failed
Booting from SD card in 8bit slot...
MMC: no card present
** Bad device mmc 1 **
MMC: no card present
** Bad device mmc 1 **

sdboot failed
Booting from USB stick...
starting USB...
USB0:   tegrausb: Invalid dr_mode 2 for host mode
lowlevel init failed
USB1:   USB EHCI 1.00
scanning bus 1 for devices... 2 USB Device(s) found
USB2:   USB EHCI 1.00
scanning bus 2 for devices... 1 USB Device(s) found
       scanning usb for storage devices... 0 Storage Device(s) found
       scanning usb for ethernet devices... 
Warning: asx0 using MAC address from net device
1 Ethernet Device(s) found
** Bad device usb 0 **
** Bad device usb 0 **

usbboot failed
Booting via DHCP/TFTP/NFS...
Waiting for Ethernet connection... unable to connect.
Waiting for Ethernet connection... unable to connect.

nfsboot failed
Colibri T30 # 

It doesn’t boot any more and is the second time it happen. The first time reinstalling all the image (u-boot, kernel and rootfs) solved the problem. The first time worked fine about 2 months. This time only work for 3 weeks.

Please, can any one help me on this.
Thank you.

That’s rather strange. Are you stressing the module in any unusual way (e.g. lots of flash wear out or power-cuts)? If this happens during regular use I guess the flash chip may be faulty and I suggest you doing an RMA mentioning this community question and we may analyse the module more closely.

Hi marcel.tx. I tried to find the posible causes with the final users. The are doing power cuts to the system and they don’t want add a power button or something.

What do you recommend? So the system work in that manner.

Updating kernel solved de problem but I think I need backup de file system and currently I am on that

Thank you
Kind regards

In theory it should of course survive such power cuts which we validated extensively running lengthy validation & verification tests in our temperature chambers. That said it is mainly dependant on resp. eMMC flash chips assembled and at times we have seen a very few of them failing in strange ways which is why I would recommend doing an RMA so we may analyse this more closely.

Ok, I’ll get another T30 because de system is currently operating and I`ll check the RMA process.

Thank you for your support.

You are very welcome.