Colibri T30 Configuration

alt text

I follow all the getting started procedure but I’m stucked here.


Do you want to flash a Linux or WinCE? And could you please provide logs not as pictures but as a text files ?

I want to flash Linux

Toradex Bootloader 2.2 for Tegra Built Dec  7 2018 15:05:43

Press [SPACE] to enter Bootloader Menu

BootLoader Configuration:

C) Clear Flash Registry
X) Enter CommandPrompt Mode
D) Download image to RAM now
F) Download image to FLASH now
L) Launch existing flash resident image now

Enter your selection: x

>reboot rcm

U-Boot SPL 2016.11-2.8.7+g5c2d46b325 (Jun 10 2020 - 17:22:21)
Trying to boot from RAM

U-Boot 2016.11-2.8.7+g5c2d46b325 (Jun 10 2020 - 17:22:21 +0000)

SoC: tegra30
Reset cause: POR
DRAM:  1 GiB
MMC:   Tegra SD/MMC: 0, Tegra SD/MMC: 1
*** Warning - bad CRC, using default environment

$ ./ -d
Colibri T30 rootfs detected
[sudo] password for ubuntu: 
bct file: ../colibri-t30_bin/colibri_t30_12MHz_NT5CC256M16CP-DI_400MHz.bct
bootloader file: ../colibri-t30_bin/u-boot-dtb-tegra.bin
load addr 0x80108000
entry addr 0x80108000
device id: 0x7030
uid:  0x015c38762557fc12
RCM version: 3.1
downloading miniloader to target at address 0x4000a000 (128916 bytes)...
\miniloader downloaded successfully
Chip UID:                0x0000000000000000015c38762557fc12
Chip ID:                 0x30
Chip ID Major Version:   0x1
Chip ID Minor Version:   0x3
Chip SKU:                0xb0 (t30)
Boot ROM Version:        0x1
Boot Device:             0x2 (EMMC)
Operating Mode:          0x3 (developer mode)
Device Config Strap:     0x0
Device Config Fuse:      0x0
SDRAM Config Strap:      0x0
sending file: ../colibri-t30_bin/colibri_t30_12MHz_NT5CC256M16CP-DI_400MHz.bct
- 6128/6128 bytes sent
../colibri-t30_bin/colibri_t30_12MHz_NT5CC256M16CP-DI_400MHz.bct sent successfully
sending file: ../colibri-t30_bin/u-boot-dtb-tegra.bin
/ 517214/517214 bytes sent
../colibri-t30_bin/u-boot-dtb-tegra.bin sent successfully

Toradex side after that dosen’t happen nothing else so I can’t execute ‘run setupdate; run update’

Dear @iozif

The link I sent you via e-mail is the proven and tested way to flash your module. It’s strange that you can’t type anything after loading u-boot to RAM. Maybe something went wrong when you downloaded the binary image or when you unpacked that image on your host computer. Could you download the binary image from here again and try the flashing with that?

Additionally, make sure you have the hardware setup as described in the article about Txx Recovery Mode. Means only connect power, USB and serial console.

If it still doesn’t work with the current module, could you try what happens when you follow the same steps with another module of yours?

Best regards

I followed the suggested steps but unfortunatley I obtain the same result with all of mine 5 toradex

HI @iozif

Which UART Receiver are you using?
Could you share the output on the console of SoM?

Toradex side after that dosen’t happen nothing else so I can’t execute ‘run setupdate; run update’

Is this the output of the console or the display?
Are you trying to typing on the console or using a Keyboard connected to the SoM?

Thanks and best regards,

I’m using a Hama 00053325 as UART reciver.The only output I can see is that I send on the photo because on the display dosen’t appear nothing after the recovery mode reboot and I tried to type on both (via uart on ubuntu and directly on the som with usb keyboard) and nothing happens.

Dear @iozif

Thank you for the call. I am happy that we found the issue. Let me summarize the solution here, so other people can find it as well.

It seems that is not possible to properly load U-Boot from images built on BSP 2.8.7 or older when you enter the recovery-mode by software (e.g. within Eboot with > reboot rcm). In this case, you have to enter the recovery-mode by hardware, e.g. connecting pin 1 and 2 from JP1 on Iris carrier board (depending on the used hardware).

Best regards