Colibri PXA270 312 V1.2 D doesn't work after re-flashing bootloader

I have a few Colibri PXA270 312 V1.2 D that I would like to bring up to date.
I tried re-flashing the bootloader on one using ColibriLoader 3.3 and bootloader V 4.5. It seems that it carries on re-flashing but afterwards the module seems to not do anything anymore.
I tried getting the bootloader menu using Tera Term or re-flashing the OS image, but nothing happens. I don’t get connection through CERHost anymore.
what can I do to get it work now? Is there another bootloader version more suitable for this module?

Dear @shiva_eghbal

The bootloader V4.5 is expected to work fine on the Colibri PXA270 V1.2D.

  • Is there any message output on the serial port when you power on the module? Please note: the PXA270 uses 9600bps by default.
  • Do you have a JTAG adapter available, or did you reflash the module over network only?

The first step is to get the serial port output back. All other actions (OS image flashing, CERHost) cannot be successful without this.

Regards, Andy

Hi @andy.tx,
I am using the Colibri Evaluation board and there is no message on Tera Term anymore as I reboot the module or try to bring the bootloader menu up using space key and reset button.
I used the JTAG cable and evaluation board and ColibriLoader to reflash the bootloader.
Since I have done this, the Tera Term doesn’t show anything anymore.
Any idea what the problem is?

Dear @shiva_eghbal,

It seems to be bootloader is corrupted, Could you please follow the description here:
Can you able to communicate through JTAG after that or that’s also not working?

I can communicate through JTAG to re-flash the bootloader.

And it seems that it is reflashing and finishing the process. But once the process ends, nothing happens. If I restart the module, nothing is written on the Tera Term anymore.
Do you know how I can get it to boot ?
If I try to re-flash again it seems to do it, but nothing changes.

Dear @shiva_eghbal

The config block does not get re-flashed when you load the bootloader through JTAG.

Maybe you had misconfigured the configblock settings in a way which prevent the module from booting. In this case the module should be unbricked by loading a proper config block through JTAG.

  • You can create a clean configblock by taking a backup using the UpdateTool on a good module.
  • I added such a backed-up configblock file below:

Regards, Andy

it looks very usefull for new people like me, would you please share the final results if possible,Thanks a lot!

I have tried getting a backup from bootloader and config block of a working module with bootloader version 3.2 and image version 1.7
I then used the bootloader download section of ColibriLoader to load this backup.bin through JTAG. A short process bar is shown and once it reaches the end, nothing happens!
I tried the file you attached as well. same thing happens.
Any idea what I can do?

On another module I tried to update the current Image (V1.7) to version 4.5 using the ColibriLoader. After that I get the following screen:

And it seems to be stuck at this point.

Dear @shiva_eghbal
Your screenshot was blocked by our system. Can you please add it again?
As a general rule, you should always use the same version of bootloader and image. It is well possible, that Eboot V4.5 cannot properly boot image V1.7.
Regards, Andy

Dear @andy.tx here is the image again:

So how can I update the bootloader and image of an old module?
I did try to update the bootloader to then update the image, but then the bootloader menu doesn’t come up anymore and nothing happens.
I have tried to use a backup of bootloader and config block but that doesn’t change anything as well.
I also tried the config that Toradex sent me, no difference!
I have couple of these old modules that I need to bring up to date to use, but as I have started to do this I now have 3 that don’t seem to work anymore.
Please let me know how I can retrieve them and how I should update the bootloader and image for the rest of them?

Can anyone help me with this?
Thank you

Dear @shiva_eghbal

I finally got an identical module as you have into my hands. I’m afraid I can confirm that flashing the V1.2D module does not work with ColibriLoader. If you turn on the verification tick mark, you will see that the tool reports a verification error for the first blocks already.
However, it works all fine on V2.4 modules.

We recently get very few requests on PXA270 modules, therefore debugging the ColibriLoader is not our preferred solution. My suggestion is:

  1. For the modules still running Windows CE, you can use the UpdateTool to update the OS to V2.4
  2. As long as there is still a working bootloader on the modules, there’s also an option to use ColibriLoader over Ethernet to flash the system. This is more complex to setup and more risky to render the module unbootable, therefore I only recommend it if WinCe is not working anymore, but the bootloader is.
  3. For the non-bootable modules I can offer you to send them back to us. We will run them through our regular production tester, which will flash the OS image as part of the process.
    If there are not too many modules, we can do this also for cases 1. and 2. above.

Please let me know whether you are fine with this approach.