Colibri IMX8QXP losing network and USB after flashing for the first time

I’m using a viola 1.2 board with Colibri IMX8QXP 2GB WB IT 1.0D

After I flash a custom image of Torizon on the SoM I lose all ability to reflash it since even when in recovery mode neither the ethernet or USB are detected by Toradex Easy Installer. Ethernet and USB does not work with flashed image as well. I tried with two different modules and both stopped working.

I have an IMX7 that I used to check if it is a board issue and it all seems to be correct with the board.

When I do recovery I tried intrrupting the bootloader so I can check the networking hardware directly with mdio command and the chip seems to be responding and detecting the connection of the cable correctly.

Colibri iMX8X TEZI # mdio list
0 - Generic PHY <--> ethernet@5b040000
Colibri iMX8X TEZI #

Colibri iMX8X TEZI # mdio read 2
Reading from bus FEC0
PHY at address 0:
2 - 0x22

Could you help me solve this issue?

You don’t need to enter the U-Boot command mode to access recovery mode and subsequently load the Toradex Easy Installer via the USB client. For detailed instructions, please refer to this article. However, it’s important to note that the Viola 1.2, unlike the Viola 1.2 Plus, doesn’t come with a pre-installed USB client connector (X4). This means that loading the Toradex Easy Installer isn’t feasible on the Viola 1.2.

Given this situation, you have two potential solutions:

  1. Consider acquiring a different carrier board, such as the Iris or the Colibri Evaluation board.
  2. Alternatively, you can manually solder the X4 connector and ensure the inclusion of the 0-Ohm resistors R55 and R56.

I seem to be misunderstood. I am able to load Toradex Easy Installer. Board is Viola Plus V1.2B.

On my IMX7 module I see the ethernet PHY Micrel KSZ804 is correctly identified by U-Boot

Colibri iMX7 # mdio list
0 - Micrel KSZ804 <--> ethernet@30be0000

But on IMX8 modules I only see Generic PHY

Colibri iMX8X TEZI # mdio list
0 - Generic PHY <--> ethernet@5b040000

If you’ve successfully loaded the Toradex Easy Installer, there’s no need to interrupt the bootloader. Simply use the Toradex Easy Installer GUI to flash the OS image provided by Toradex. Once this is done, you can interrupt the newly flashed bootloader if you need so.

The ethernet does not work. So I jumped into the bootloader to check if there was something strange in there and it seems it does.

Also, bootloader from IMX7 initialization shows version 5.7.2 but dates of July

CPU:   Freescale i.MX7D rev1.3 1000 MHz (running at 792 MHz)
CPU:   Extended Commercial temperature grade (-20C to 105C) at 25C
Reset cause: POR
DRAM:  1 GiB
PMIC:  RN5T567 LSIVER=0x01 OTPVER=0x0d
Loading Environment from MMC... OK
In:    serial
Out:   serial
Err:   serial
Model: Toradex Colibri iMX7 Dual 1GB (eMMC) V1.1A, Serial# 06464635
SEC0: RNG instantiated
Net:   eth0: ethernet@30be0000
Hit any key to stop autoboot:  0

Bootloader for IMX8 shows version 5.7.3 but dates of April.

U-Boot 2020.04-5.7.3+git.4b72b1453285 (Jul 25 2023 - 14:16:56 +0000)

CPU:   NXP i.MX8QXP RevC A35 at 1200 MHz at 29C

DRAM:  2 GiB
Loading Environment from MMC... *** Warning - bad CRC, using default environment

In:    serial
Out:   serial
Err:   serial
Model: Toradex Colibri iMX8 QuadXPlus 2GB Wi-Fi / BT IT V1.0D, Serial# 07253642

  - SCFW 216a2c2e, SECO-FW c9de51c0, IMX-MKIMAGE 6a315dbc, ATF 2fa8c63
  - U-Boot 2020.04-5.7.3+git.4b72b1453285 

Detect USB boot. Will enter fastboot mode!
Net:   eth0: ethernet@5b040000 [PRIME]
Fastboot: Normal
Boot from USB for mfgtools
*** Warning - Use default environment for 				 mfgtools
, using default environment

Run bootcmd_mfg: select_dt_from_module_version && fastboot 0
Hit any key to stop autoboot:  0

Please try to lash some image provided by Toradex.

I’m trying to to exactly that, but I can neither use the ethernet to load the image nor the USB. If there is another way to flash this module I do not know of.

You can use an SD card to flash an image from. However, if the Ethernet still isn’t functioning with the Toradex Easy Installer, it might indicate a hardware problem with your module.

I’ll try the SD interface.

If it is a hardware problem with module what are the steps I should do to restore it? Since it was working before on same board and only software was changed. How can I be certain it is a hardware problem?

I still think it is a misconfiguration on the U-boot because of the IC answering the register values and accepting commands, but it being mislabeled as “Generic PHY” on the U-Boot.

I see Viola does have SD, I’ll try that.

With SD card I could reflash a new image of ToradexEasyInstaler downloaded from Toradex. I still have no signal on the ethernet.

Also, the system now keeps rebooting.

I managed to flash Colibri-iMX8X_Reference-Minimal-Image-Tezi_5.7.2+build.21
The system keeps rebooting autonomously, but it seems the ethernet driver is correctly recognized, but still no network is available.

Are you able to reproduce my problem?

No, Ethernet and USB work as expected. Looks like you have a HW issue. Please fill out this RMA form.