Colibri IMX8 WiFi device is not created


We are trying to set up a WiFi Access Point with Hostapd while using Torizon. We have built our own TorizonCore with Yocto. Currently, there is no device appearing in our build with iw dev. We have tried to set up an Access Point before with one of your Torizon builds with successful results. We are aware of the known issues TOR-979 and TOR-980. We have included the mwifiex.conf file in /etc/modprobe.d/, but the uap0 device doesn’t appear no matter how many times we reboot.

We have tried to build the TorizonCore with both 5.x.x Dunfell & 4.x.x Zeus where iw dev returns nothing on 5.x.x and nl80211 not found on 4.x.x. We are primarily working on 4.x.x Zeus.

We would like to have help with some type of workaround if there is no solution to this in the near future.

Greetings @Jacmo,

For TOR-979 and TOR-980 I believe a fix was already committed to our Yocto layers. I’m not sure at what point in the commit history you based your Yocto build on but it may have been before this fix. I did some digging and this was the commit that ultimately fixed those issues:

Try seeing if this fix is in your layers and if not then go ahead and try adding it and see if that resolves the issues on 4.0.

As for 5.0 there’s actually a different bug, TOR-1465. However this bug was also fixed within the past week or so by this commit: torizon-core-common: remove backports from image · toradex/meta-toradex-torizon@4dafe7e · GitHub

I would suggest integrating these fixes into your build if they are not already. If they already are or they don’t fix anything, then please provide try the following. Try flashing an unmodified 4.0/5.0 image from us, see if you can recreate the issue there. If yes then please provide me with the exact steps you did to cause this issue on the device so I can reproduce on my end. If you can’t recreate with an unmodified image then I would need to know what kind of changes you’re making in Yocto.

Finally you said you set up an access point on Torizon previously, what changes between then and now?

Best Regards,