Colibri iMX8 v1.0B: core-image-full-cmdline with wifi support

I build the fsl-image successfully with this article and were able to connect to a wifi network with connmanctl (link).

Then I tried the same with the ‘core-image-full-cmdline’ (path: \sources\poky\meta\recipes-extended\images). Therefore I modified the recipe like this:

DESCRIPTION = "A console-only image with more full-featured Linux system \
functionality installed."

IMAGE_FEATURES += "splash ssh-server-openssh"

IMAGE_INSTALL = "\
    packagegroup-core-boot \
    packagegroup-core-full-cmdline \
    connman \
    connman-client \
    linux-firmware-pcie8997 \
	openssh-sftp-server \
    ${CORE_IMAGE_EXTRA_INSTALL} \
    "

inherit core-image

I build the image with

MACHINE=colibri-imx8qxp DISTRO=fsl-imx-xwayland source fsl-setup-release.sh -b build
bitbake -k core-image-full-cmdline

The build was successfull and it booted.

But when I tried to connect to a wifi network I got the following error message:

root@colibri-imx8qxp:~# connmanctl enable wifi
Error wifi: Method "SetProperty" with signature "sv" on interface "net.connman.Technology" doesn't exist

What did I miss?

hi @Mowlwurf

Could you provide the dmesg log and the output of ‘lsmod’ in a file?

Thanks and best regards,
Jaski

Here is the dmesg log file: dmesg log file

The output of ‘lsmod’ is just

Module                  Size  Used by

and nothing more.

Best regards,
Mowlwurf

Hi @Mowlwurf

You need to add at least the following to the .bb file.

${@bb.utils.contains("DISTRO_FEATURES", "wifi", "packagegroup-base-wifi", "", d)} \

I tested this with the following additional package added:

packagegroup-base \
packagegroup-distro-base \  	
packagegroup-machine-base \

And the built core-image-full-cmdline had the wifi support.

As alternative, I suggest to check out the Bsp 3.0 branch and build the console image. This image will be one of our regular Bsp Image in the Future and thus you will get better Support for this.

Best regards,
Jaski

Thank you for your response,

yes, I got wifi support too. But when I try to connect to a network I got an error scanning for wifi:

root@colibri-imx8qxp:~# connmanctl
connmanctl> enable wifi
Enabled wifi
connmanctl> scan wifi
Scan completed for wifi
connmanctl> [  276.774192] ieee80211 phy0: mwifiex_cfg80211_sched_scan_start : Invalid Sched_scan parameters

Any idea what can be the cause for this?

Best regards,
Mowlwurf

You are welcome.

Concerning your issue, this is just a debug message.

Are you able to connect to the Wifi router or access-point.?

Sorry for my late reply. It didn’t get a notification of your comment.

I was able to connect to my access-point, thank you again for your help

Perfect that it works. Thanks for the feedback.