Colibri IMX7D V1.1D not working, 1.1C worked fine

We have an ethernet interface on our host board which worked fine with 1.1C. However, on the new 1.1D version SOMs the ethernet interface is completely non-functional. No ethernet jacks lights flash upon powerup, whereas before they did and interface worked fine.

REV 1.1C works in our host board and the Calibri eval board.
REV 1.1D does not work in our host board, but works fine on the Calibri eval board.

All other functions of the SOM work perfectly fine in both boards (our host board and the Calibri eval board).
In reviewing the 1.1D change notice the only thing that we saw that might relate to this was VCC_Batt and or potentially UHS1. W/respect to VCC_Batt, on the eval board there is a diode between V3.3D and the pin, whereas on our board VCC_Batt is directly connected to V3.3D.

Dear @rhewitt,

thank you very much for using the developer community. I am sorry about the issues you are experiencing.

Could you please send to my email address ( the serial number of your product Colibri IMX7D 512MB V1.1D?
Do you have only one unit with this version or more than one?

Could you please also be so kind to share with me the Ethernet schematic file of your carrier board? I would like to see if there is any difference that could explain this effect.

Thanks a lot for your help, I wish you a nice weekend.