Colibri imx6ull with wifi/bluetooth issue with reloading Easy Installer

This might be more FYI for others, but I had some issues trying to reload tezi on a colibri imx6ull with wifi/bluetooth on the colibri eval board. I had built the multimedia image without any modifications and loaded it just fine using the tezi that came installed on the module. Once I had verified what I needed, I wanted to go back to tezi and load a different image. Because of issues I won’t dive into, I needed to put tezi on a USB stick and load using the procedures documented. I grabbed the latest imx6ull tezi image and tried it. No love, as I got:

Colibri iMX6ULL # run bootcmd_usb0
starting USB...
Bus usb@2184000: USB EHCI 1.00
Bus usb@2184200: USB EHCI 1.00
scanning bus usb@2184000 for devices... 1 USB Device(s) found
scanning bus usb@2184200 for devices... 5 USB Device(s) found
       scanning usb for storage devices... 1 Storage Device(s) found

Device 0: Vendor: HP       Rev: 0.00 Prod: v125w
            Type: Removable Hard Disk
            Capacity: 3853.5 MB = 3.7 GB (7892040 x 512)
... is now current device
Scanning usb 0:1...
Found U-Boot script /boot.scr
543 bytes read in 2 ms (264.6 KiB/s)
## Executing script at 87000000
33272124 bytes read in 1503 ms (21.1 MiB/s)
## Loading kernel from FIT Image at 82200000 ...
Could not find configuration node
ERROR: can't get kernel image!
SCRIPT FAILED: continuing...
Colibri iMX6ULL #

I tried a few other versions of tezi for this module to no avail. I then tried erasing the uboot env and using the default env. Still no love…

After looking at the fit image itself, I noticed there was no configuration for “imx6ull-colibri-wifi-eval-v3.dtb” but there was for “imx6ull-colibri-eval-v3.dtb”. The uboot env for this module creates the $fdtfile variable using
preboot=setenv fdtfile imx6ull-colibri${variant}-${fdt_board}.dtb
and $variant is set to -wifi (I didn’t set it that way).
I then removed variant using “setenv variant; saveenv” and tried again. Everything worked just fine after that (well, tezi started and that was my goal).
So, not sure if Toradex needs to add a new configuration to the imx6ull tezi image for that specific module or add some sort of test in the boot script to remove that piece.
Of course, I noticed all of the “not fully supported by Toradex” stuff in the docs for USB loading of tezi, so there’s that :wink:

1 Like

Could you please share the TEZI realis version you were dealing with?

I tried a few from Loading Toradex Easy Installer. All were whatever was up there on October 2-5 for the imx6ull:

  • Stable release 1.8
  • Colibri iMX6ULL (2021-10-01 | 5.4.0+build.4 | 32.43 MB)